[Nagiosplug-devel] Extra opts help text

Ton Voon ton.voon at opsera.com
Tue Apr 13 19:14:10 CEST 2010


I wanted to get some opinions about the --extra-opts help text. In the  
C code it reads (with typo):

   Read additionnal options from ini file

[further down between notes and example]

See: http://nagiosplugins.org/extra-opts for --extra-opts usage and  

However, the Nagios::Plugin library says:

    Section and/or config_file from which to load extra options (may  

Note a difference in syntax. I'd like to harmonise these and make it  
more readable.

A colleague says that "additional options" or "extra opts" suggests  
there are other options not available through the command line. I  
don't want to change the parameter, but I propose that the text be  
changed to:

    Read options from an ini file. See http://nagiosplugins.org/extra-opts 
  for usage

For both libraries.

Any objections?


More information about the Devel mailing list