summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..c10568c
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,12 @@
1use 5.008004;
2use ExtUtils::MakeMaker;
3# See lib/ExtUtils/MakeMaker.pm for details of how to influence
4# the contents of the Makefile that is written.
5WriteMakefile(
6 NAME => 'Nagios::Plugin',
7 VERSION_FROM => 'lib/Nagios/Plugin.pm', # finds $VERSION
8 PREREQ_PM => {}, # e.g., Module::Name => 1.1
9 ($] >= 5.005 ? ## Add these new keywords supported since 5.005
10 (ABSTRACT_FROM => 'lib/Nagios/Plugin.pm', # retrieve abstract from module
11 AUTHOR => 'Ton Voon <ton.voon@altinity.com>') : ()),
12);