summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorKarl DeBisschop <kdebisschop@users.sourceforge.net>2002-11-09 03:43:12 (GMT)
committerKarl DeBisschop <kdebisschop@users.sourceforge.net>2002-11-09 03:43:12 (GMT)
commit92a9e9a0439a0afb2477d6189ea09cfddaea1d2c (patch)
tree547cb5b9465644a283a22fc6a7baf0d98d56a914 /configure.in
parent731426203c88b76255492ad69138e6ecc7b0c7b5 (diff)
downloadmonitoring-plugins-92a9e9a0439a0afb2477d6189ea09cfddaea1d2c.tar.gz
add HPUX swap, try to cleanup getopt processing
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@179 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 12 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index bdd4013..4f2a4ac 100644
--- a/configure.in
+++ b/configure.in
@@ -358,14 +358,14 @@ AC_TRY_COMPILE([#include <getopt.h>
358 static struct option *long_options; 358 static struct option *long_options;
359 getopt_long(0,NULL,"+h",long_options,&option_index);], 359 getopt_long(0,NULL,"+h",long_options,&option_index);],
360 [AC_DEFINE(HAVE_GETOPT_H,1,[Define if getopt headers are found]) 360 [AC_DEFINE(HAVE_GETOPT_H,1,[Define if getopt headers are found])
361 AC_DEFINE(HAVE_GETOPT_LONG,1,[Define if getopt_long_only() is found]) 361 AC_DEFINE(HAVE_GETOPT_LONG,1,[Define if getopt_long is found])
362 AC_MSG_RESULT(yes)], 362 AC_MSG_RESULT(yes)],
363 [AC_DEFINE(HAVE_GETOPT_H,1,[Define if getopt headers are found]) 363 [AC_DEFINE(HAVE_GETOPT_H,1,[Define if getopt headers are found])
364 AC_DEFINE(HAVE_GETOPT_LONG,1,[Define if getopt_long_only() is found]) 364 AC_DEFINE(HAVE_GETOPT_LONG,1,[Define if getopt_long is found])
365 AC_MSG_RESULT(no) 365 AC_MSG_RESULT(no)
366 import_sources=getopt]) 366 import_sources=getopt
367 367 LIBS="$LIBS -lgetopt"
368AC_CHECK_FUNCS(getopt_long_only,,LIBS="$LIBS -lgetopt" DEPLIBS="$DEPLIBS libgetopt.a") 368 DEPLIBS="$DEPLIBS libgetopt.a"])
369 369
370AC_TRY_COMPILE([#include <sys/time.h>], 370AC_TRY_COMPILE([#include <sys/time.h>],
371 [struct timeval *foo;], 371 [struct timeval *foo;],
@@ -859,6 +859,13 @@ then
859 echo " using FreeBSD format" 859 echo " using FreeBSD format"
860 fi 860 fi
861 EXTRAS="$EXTRAS check_swap" 861 EXTRAS="$EXTRAS check_swap"
862elif [swapinfo -d 2>/dev/null | egrep -i "^TYPE +AVAIL +USED +FREE" >/dev/null]
863then
864 AC_DEFINE(HAVE_SWAP,1,[Define if swap/swapinfo command is found])
865 AC_PATH_PROG(PATH_TO_SWAP,swapinfo)
866 AC_DEFINE_UNQUOTED(SWAP_COMMAND,"/bin/sh '$PATH_TO_SWAP -d | /bin/tail -l +2'",[Path to swap/swapinfo binary, with any args])
867 AC_DEFINE_UNQUOTED(SWAP_FORMAT,["%*s %d %*d %d"],[Format string for parsing swap output ])
868 echo " using HP-UX format HP-UX"
862fi 869fi
863 870
864AC_PATH_PROG(PATH_TO_DIG,dig) 871AC_PATH_PROG(PATH_TO_DIG,dig)