summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorKarl DeBisschop <kdebisschop@users.sourceforge.net>2002-11-14 18:25:10 (GMT)
committerKarl DeBisschop <kdebisschop@users.sourceforge.net>2002-11-14 18:25:10 (GMT)
commitc77ffcedc423655621be9803b7f710c758a959b7 (patch)
treebf61006f5399497f83fdd9de9fddad5048512c28 /configure.in
parentbe0cbafb0be470dcd3d29c20d7c5ce503c467bd4 (diff)
downloadmonitoring-plugins-c77ffcedc423655621be9803b7f710c758a959b7.tar.gz
fix bug with gettimeofday test, improve version/release handling, update rpm spec
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@200 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 15 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index c673018..509b623 100644
--- a/configure.in
+++ b/configure.in
@@ -3,11 +3,15 @@ include(`aclocal.m4')
3include(`getloadavg.m4') 3include(`getloadavg.m4')
4AC_REVISION ($Revision$) 4AC_REVISION ($Revision$)
5AC_INIT(Helper.pm) 5AC_INIT(Helper.pm)
6PACKAGE_VERSION="1.3.0" 6VER=1.3.0
7REL=beta2
8AC_SUBST(VER)
9AC_SUBST(REL)
10PACKAGE_VERSION="${VER}-${REL}"
7AC_SUBST(PACKAGE_VERSION) 11AC_SUBST(PACKAGE_VERSION)
8PACKAGE_RELEASE="alpha1" 12PACKAGE_RELEASE="alpha1"
9AC_SUBST(PACKAGE_RELEASE) 13AC_SUBST(PACKAGE_RELEASE)
10AM_INIT_AUTOMAKE(nagios-plugins,${PACKAGE_VERSION}-${PACKAGE_RELEASE}) 14AM_INIT_AUTOMAKE(nagios-plugins,${PACKAGE_VERSION})
11AM_CONFIG_HEADER(plugins/config.h plugins/common.h plugins/version.h plugins/netutils.h plugins/utils.h plugins/popen.h) 15AM_CONFIG_HEADER(plugins/config.h plugins/common.h plugins/version.h plugins/netutils.h plugins/utils.h plugins/popen.h)
12 16
13AC_PREFIX_DEFAULT(/usr/local/nagios) 17AC_PREFIX_DEFAULT(/usr/local/nagios)
@@ -366,12 +370,15 @@ AC_TRY_COMPILE([#include <getopt.h>
366 DEPLIBS="$DEPLIBS libgetopt.a"]) 370 DEPLIBS="$DEPLIBS libgetopt.a"])
367 371
368AC_TRY_COMPILE([#include <sys/time.h>], 372AC_TRY_COMPILE([#include <sys/time.h>],
369 [struct timeval *foo;], 373 [struct timeval *tv;
370 [AC_DEFINE(HAVE_STRUCT_TIMEVAL,1,[Define if we have a timeval structure])]) 374 struct timezone *tz;],
371 375 AC_DEFINE(HAVE_STRUCT_TIMEVAL,1,[Define if we have a timeval structure])
372AC_TRY_COMPILE([#include <sys/time.h>], 376 AC_TRY_COMPILE([#include <sys/time.h>],
373 [gettimeofday(NULL, NULL);], 377 [struct timeval *tv;
374 AC_DEFINE(HAVE_GETTIMEOFDAY,1,[Define if gettimeofday is found])) 378 struct timezone *tz;
379 gettimeofday(tv, tz);],
380 AC_DEFINE(HAVE_GETTIMEOFDAY,1,[Define if gettimeofday is found]),
381 AC_DEFINE(NEED_GETTIMEOFDAY,1,[Define if gettimeofday is needed])))
375 382
376dnl Checks for library functions. 383dnl Checks for library functions.
377AC_CHECK_FUNCS(memmove select socket strdup strstr strtod strtol strtoul) 384AC_CHECK_FUNCS(memmove select socket strdup strstr strtod strtol strtoul)