summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2003-02-10 23:26:14 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2003-02-10 23:26:14 (GMT)
commitfb6811f9be0d85f5fceedb3ba7458e56386fc3a0 (patch)
tree97e13020eef374cc9dd1f1de400dbad701235124 /configure.in
parente3f565cfd9328af4014ee70f95a8852ce4629959 (diff)
downloadmonitoring-plugins-fb6811f9be0d85f5fceedb3ba7458e56386fc3a0.tar.gz
Removing checks for getopt.h - now always available. Also support lib dir
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@309 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 1 insertions, 19 deletions
diff --git a/configure.in b/configure.in
index cc9f96c..81a0029 100644
--- a/configure.in
+++ b/configure.in
@@ -373,24 +373,6 @@ if test x"$ac_cv_HAVE_SNPRINTF" = x"no" -o x"$ac_cv_HAVE_VSNPRINTF" = x"no" -o x
373 LIBS="$LIBS -lsnprintf" DEPLIBS="$DEPLIBS libsnprintf.a" 373 LIBS="$LIBS -lsnprintf" DEPLIBS="$DEPLIBS libsnprintf.a"
374fi 374fi
375 375
376dnl We used to not do long options unless a compatible lib was found
377dnl Now we provide code and make libgetopt if native is not suitable
378AC_MSG_CHECKING(for getopt_long)
379AC_TRY_COMPILE([#include <getopt.h>
380 #include <stdlib.h>],
381 [int option_index=0;
382 static struct option *long_options;
383 getopt_long(0,NULL,"+h",long_options,&option_index);],
384 [AC_DEFINE(HAVE_GETOPT_H,1,[Define if getopt headers are found])
385 AC_DEFINE(HAVE_GETOPT_LONG,1,[Define if getopt_long is found])
386 AC_MSG_RESULT(yes)],
387 [AC_DEFINE(HAVE_GETOPT_H,1,[Define if getopt headers are found])
388 AC_DEFINE(HAVE_GETOPT_LONG,1,[Define if getopt_long is found])
389 AC_MSG_RESULT(no)
390 import_sources=getopt
391 LIBS="$LIBS -lgetopt"
392 DEPLIBS="$DEPLIBS libgetopt.a"])
393
394AC_TRY_COMPILE([#include <sys/time.h>], 376AC_TRY_COMPILE([#include <sys/time.h>],
395 [struct timeval *tv; 377 [struct timeval *tv;
396 struct timezone *tz;], 378 struct timezone *tz;],
@@ -956,4 +938,4 @@ AC_SUBST(DEPLIBS)
956 938
957AC_DEFINE_UNQUOTED(PACKAGE_VERSION,"${VERSION}",[package version]) 939AC_DEFINE_UNQUOTED(PACKAGE_VERSION,"${VERSION}",[package version])
958 940
959AC_OUTPUT(Makefile subst plugins/Makefile plugins-scripts/Makefile plugins-scripts/subst plugins-scripts/utils.pm plugins-scripts/utils.sh command.cfg test.pl,echo timestamp > plugins/stamp-h1;echo timestamp > plugins/stamp-h2;echo timestamp > plugins/stamp-h3;echo timestamp > plugins/stamp-h4;echo timestamp > plugins/stamp-h5;echo timestamp > plugins/stamp-h6;PATH=.:..:$PATH subst.sh command.cfg) 941AC_OUTPUT(Makefile subst lib/Makefile plugins/Makefile plugins-scripts/Makefile plugins-scripts/subst plugins-scripts/utils.pm plugins-scripts/utils.sh command.cfg test.pl,echo timestamp > plugins/stamp-h1;echo timestamp > plugins/stamp-h2;echo timestamp > plugins/stamp-h3;echo timestamp > plugins/stamp-h4;echo timestamp > plugins/stamp-h5;echo timestamp > plugins/stamp-h6;PATH=.:..:$PATH subst.sh command.cfg)