summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2007-03-25 13:55:14 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2007-03-25 13:55:14 (GMT)
commitddd8e7e22e01a94326696d0e30a704d74c1a2f38 (patch)
treeb4b4c0902d73dce6523aa2eb6e2c18f5d582fed1 /configure.in
parentb6a9796625c49c6bd73bd64066ae5276d74b1dfd (diff)
downloadmonitoring-plugins-ddd8e7e22e01a94326696d0e30a704d74c1a2f38.tar.gz
Reinstate --with-nagios-user/group and new --without-group-permissions ./configure options
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1649 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 22 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 3b8db84..fe8f112 100644
--- a/configure.in
+++ b/configure.in
@@ -15,13 +15,29 @@ AC_SUBST(RELEASE)
15AC_PREFIX_DEFAULT(/usr/local/nagios) 15AC_PREFIX_DEFAULT(/usr/local/nagios)
16 16
17dnl Deprecated configure options 17dnl Deprecated configure options
18AC_ARG_WITH(nagios_user,,
19 AC_MSG_ERROR([--with-nagios-user is a deprecated option. Rerun ./configure without this option]))
20AC_ARG_WITH(nagios_group,,
21 AC_MSG_ERROR([--with-nagios-group is a deprecated option. Rerun ./configure without this option]))
22 18
23dnl Figure out how to invoke "install" and what install options to use. 19
24AC_PROG_INSTALL 20dnl Append user (-o), group (-g), mode (-m) to install command
21dnl There is an assumption that this is possible with ./configure's chosen install command
22extra_install_args=""
23AC_ARG_WITH(nagios_user,
24 ACX_HELP_STRING([--with-nagios-user=USER],
25 [Installs executables with this user. Defaults to install user]),
26 extra_install_args="-o $withval")
27AC_ARG_WITH(nagios_group,
28 ACX_HELP_STRING([--with-nagios-group=GROUP],
29 [Installs executables with this group. Defaults to install user]),
30 extra_install_args="$extra_install_args -g $withval")
31AC_ARG_WITH(world_permissions,
32 ACX_HELP_STRING([--without-world-permissions],
33 [Installs executables without world permissions]))
34
35if test "x$with_world_permissions" = xno ; then
36 extra_install_args="$extra_install_args -m 0550"
37fi
38
39INSTALL="$INSTALL $extra_install_args"
40INSTALL_STRIP_PROGRAM="$INSTALL_STRIP_PROGRAM $extra_install_args"
25AC_SUBST(INSTALL) 41AC_SUBST(INSTALL)
26 42
27AC_PROG_CC 43AC_PROG_CC