summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index b76bf76..5c25f33 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
1## Process this file with automake to produce Makefile.in 1## Process this file with automake to produce Makefile.in
2 2
3SUBDIRS = gl lib plugins plugins-scripts plugins-root po 3SUBDIRS = gl lib plugins plugins-scripts plugins-root po @PERLMODS_DIR@
4 4
5EXTRA_DIST = config.rpath \ 5EXTRA_DIST = config.rpath \
6 ABOUT-NLS ACKNOWLEDGEMENTS AUTHORS BUGS CODING FAQ LEGAL NEWS \ 6 ABOUT-NLS ACKNOWLEDGEMENTS AUTHORS BUGS CODING FAQ LEGAL NEWS \
@@ -23,8 +23,9 @@ install-root:
23 23
24test: 24test:
25 cd lib && $(MAKE) test 25 cd lib && $(MAKE) test
26 cd plugins; $(MAKE) test 26 if test "$(PERLMODS_DIR)" != ""; then cd perlmods && $(MAKE) test; fi
27 cd plugins-scripts; $(MAKE) test 27 cd plugins && $(MAKE) test
28 cd plugins-scripts && $(MAKE) test
28 29
29nagios-plugins.spec: nagios-plugins.spec.in 30nagios-plugins.spec: nagios-plugins.spec.in
30 sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;s/^%%{requires}$$//" $? > $@ 31 sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;s/^%%{requires}$$//" $? > $@