summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bf12995..2291c51 100644
--- a/configure.ac
+++ b/configure.ac
@@ -385,6 +385,32 @@ if test "$ac_cv_header_wtsapi32_h" = "yes"; then
385 AC_SUBST(WTSAPI32LIBS) 385 AC_SUBST(WTSAPI32LIBS)
386fi 386fi
387 387
388AC_ARG_ENABLE(check-curl,
389 AC_HELP_STRING([--enable-check-curl],
390 [Enables compilation of check_curl (default: no)]),
391 [enable_check_curl=$enableval],
392 [enable_check_curl=no])
393if test "$enable_check_curl" = "yes" ; then
394 dnl Check for cURL library
395 LIBCURL_CHECK_CONFIG(yes, 7.15.2, [
396 EXTRAS="$EXTRAS check_curl\$(EXEEXT)"
397 LIBCURLINCLUDE="$LIBCURL_CPPFLAGS"
398 LIBCURLLIBS="$LIBCURL"
399 LIBCURLCFLAGS="$LIBCURL_CPPFLAGS"
400 AC_SUBST(LIBCURLINCLUDE)
401 AC_SUBST(LIBCURLLIBS)
402 AC_SUBST(LIBCURLCFLAGS)
403 AC_SUBST(PICOHTTPPARSER_DIR, picohttpparser)
404 AC_SUBST(URIPARSER_DIR, uriparser)
405 ], [
406 AC_MSG_WARN([Skipping curl plugin])
407 AC_MSG_WARN([install libcurl libs to compile this plugin (see REQUIREMENTS).])
408 ])
409fi
410AM_CONDITIONAL([WITH_CHECK_CURL], [test "$enable_check_curl" = "yes"])
411AM_COND_IF([WITH_CHECK_CURL],
412 [AC_CONFIG_FILES([plugins/picohttpparser/Makefile plugins/uriparser/Makefile])])
413
388dnl Fallback to who(1) if the system doesn't provide an utmpx(5) interface 414dnl Fallback to who(1) if the system doesn't provide an utmpx(5) interface
389if test "$ac_cv_header_utmpx_h" = "no" -a "$ac_cv_header_wtsapi32_h" = "no" 415if test "$ac_cv_header_utmpx_h" = "no" -a "$ac_cv_header_wtsapi32_h" = "no"
390then 416then
@@ -1882,4 +1908,6 @@ ACX_FEATURE([enable],[perl-modules])
1882ACX_FEATURE([with],[cgiurl]) 1908ACX_FEATURE([with],[cgiurl])
1883ACX_FEATURE([with],[trusted-path]) 1909ACX_FEATURE([with],[trusted-path])
1884ACX_FEATURE([enable],[libtap]) 1910ACX_FEATURE([enable],[libtap])
1911ACX_FEATURE([enable],[check-curl])
1912ACX_FEATURE([with],[libcurl])
1885 1913