summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac53
1 files changed, 51 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bf12995..7c17dcd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
1dnl Process this file with autoconf to produce a configure script. 1dnl Process this file with autoconf to produce a configure script.
2AC_PREREQ(2.59) 2AC_PREREQ(2.59)
3AC_INIT(monitoring-plugins,2.2) 3AC_INIT(monitoring-plugins,2.3git)
4AC_CONFIG_SRCDIR(NPTest.pm) 4AC_CONFIG_SRCDIR(NPTest.pm)
5AC_CONFIG_FILES([gl/Makefile]) 5AC_CONFIG_FILES([gl/Makefile])
6AC_CONFIG_AUX_DIR(build-aux) 6AC_CONFIG_AUX_DIR(build-aux)
@@ -385,6 +385,42 @@ if test "$ac_cv_header_wtsapi32_h" = "yes"; then
385 AC_SUBST(WTSAPI32LIBS) 385 AC_SUBST(WTSAPI32LIBS)
386fi 386fi
387 387
388_can_enable_check_curl=no
389dnl Check for cURL library
390LIBCURL_CHECK_CONFIG(yes, 7.15.2, [
391 _can_enable_check_curl=yes
392 LIBCURLINCLUDE="$LIBCURL_CPPFLAGS"
393 LIBCURLLIBS="$LIBCURL"
394 LIBCURLCFLAGS="$LIBCURL_CPPFLAGS"
395 AC_SUBST(LIBCURLINCLUDE)
396 AC_SUBST(LIBCURLLIBS)
397 AC_SUBST(LIBCURLCFLAGS)
398 ], [
399 _can_enable_check_curl=no
400 AC_MSG_WARN([Skipping curl plugin])
401 AC_MSG_WARN([install libcurl libs to compile this plugin (see REQUIREMENTS).])
402])
403
404dnl Check for uriparser library
405URIPARSER_CHECK(yes, 0.7.5, [
406 URIPARSERINCLUDE="$URIPARSER_CPPFLAGS"
407 URIPARSERLIBS="$URIPARSER"
408 URIPARSERCFLAGS="$URIPARSER_CPPFLAGS"
409 AC_SUBST(URIPARSERINCLUDE)
410 AC_SUBST(URIPARSERLIBS)
411 AC_SUBST(URIPARSERCFLAGS)
412 ], [
413 _can_enable_check_curl=no
414 AC_MSG_WARN([Skipping curl plugin])
415 AC_MSG_WARN([install the uriparser library to compile this plugin (see REQUIREMENTS).])
416])
417
418dnl prerequisites met, enable the plugin
419if test x$_can_enable_check_curl = xyes; then
420 EXTRAS="$EXTRAS check_curl\$(EXEEXT)"
421fi
422AC_CONFIG_FILES([plugins/picohttpparser/Makefile])
423
388dnl Fallback to who(1) if the system doesn't provide an utmpx(5) interface 424dnl Fallback to who(1) if the system doesn't provide an utmpx(5) interface
389if test "$ac_cv_header_utmpx_h" = "no" -a "$ac_cv_header_wtsapi32_h" = "no" 425if test "$ac_cv_header_utmpx_h" = "no" -a "$ac_cv_header_wtsapi32_h" = "no"
390then 426then
@@ -1016,6 +1052,10 @@ if test -n "$ac_cv_ps_varlist" ; then
1016 AC_DEFINE(PS_USES_PROCETIME,"yes", 1052 AC_DEFINE(PS_USES_PROCETIME,"yes",
1017 [Whether the ps utility uses the "procetime" field]) 1053 [Whether the ps utility uses the "procetime" field])
1018 fi 1054 fi
1055 if echo "$ac_cv_ps_varlist" | grep "procpcpu" >/dev/null; then
1056 AC_DEFINE(PS_USES_PROCPCPU,"yes",
1057 [Whether the ps utility uses the "procpcpu" field])
1058 fi
1019fi 1059fi
1020 1060
1021AC_PATH_PROG(PATH_TO_PING,ping) 1061AC_PATH_PROG(PATH_TO_PING,ping)
@@ -1060,6 +1100,14 @@ then
1060 ac_cv_ping_packets_first=yes 1100 ac_cv_ping_packets_first=yes
1061 AC_MSG_RESULT([$with_ping_command]) 1101 AC_MSG_RESULT([$with_ping_command])
1062 1102
1103elif $PATH_TO_PING -4 -n -U -w 10 -c 1 127.0.0.1 2>/dev/null | \
1104 egrep -i "^round-trip|^rtt" >/dev/null
1105then
1106 # check if -4 is supported - issue #1550
1107 with_ping_command="$PATH_TO_PING -4 -n -U -w %d -c %d %s"
1108 ac_cv_ping_packets_first=yes
1109 ac_cv_ping_has_timeout=yes
1110 AC_MSG_RESULT([$with_ping_command])
1063elif $PATH_TO_PING -n -U -w 10 -c 1 127.0.0.1 2>/dev/null | \ 1111elif $PATH_TO_PING -n -U -w 10 -c 1 127.0.0.1 2>/dev/null | \
1064 egrep -i "^round-trip|^rtt" >/dev/null 1112 egrep -i "^round-trip|^rtt" >/dev/null
1065then 1113then
@@ -1882,4 +1930,5 @@ ACX_FEATURE([enable],[perl-modules])
1882ACX_FEATURE([with],[cgiurl]) 1930ACX_FEATURE([with],[cgiurl])
1883ACX_FEATURE([with],[trusted-path]) 1931ACX_FEATURE([with],[trusted-path])
1884ACX_FEATURE([enable],[libtap]) 1932ACX_FEATURE([enable],[libtap])
1885 1933ACX_FEATURE([with],[libcurl])
1934ACX_FEATURE([with],[uriparser])