summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in49
1 files changed, 41 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 341add8..6d94582 100644
--- a/configure.in
+++ b/configure.in
@@ -512,16 +512,49 @@ if test -n "$PS_COMMAND" && test -n "$PS_FORMAT" && test -n "$PS_COLS" && test -
512 ac_cv_ps_cols="$PS_COLS" 512 ac_cv_ps_cols="$PS_COLS"
513 AC_MSG_RESULT([(command-line) $ac_cv_ps_command]) 513 AC_MSG_RESULT([(command-line) $ac_cv_ps_command])
514 514
515dnl Now using the pst3/kmem hack for solaris systems to avoid truncation
516elif test "$ac_cv_uname_s" = "SunOS"; then
517 #
518 # this is a very, very ugly hack, to hardcode the location for plugins
519 #
520 if test "$libexecdir" = '${exec_prefix}/libexec'; then
521 if test "$exec_prefix" = "NONE"; then
522 if test "$prefix" = "NONE"; then
523 pst3="$ac_default_prefix/libexec/pst3"
524 else
525 pst3="$prefix/libexec/pst3"
526 fi
527 else
528 pst3="$exec_prefix/libexec/pst3"
529 fi
530 else
531 pst3="$libexecdir/pst3"
532 fi
533 ac_cv_ps_command="$pst3"
534 ac_cv_ps_format="%s %d %d %d %d %d %f %s %n"
535 ac_cv_ps_varlist="[procstat,&procuid,&procpid,&procppid,&procvsz,&procrss,&procpcpu,procprog,&pos]"
536 ac_cv_ps_cols=9
537 AC_MSG_RESULT([using nagios-plugins internal ps command (pst3) for solaris])
538 if test `isainfo -b` = 64 ; then
539 PST3CFLAGS="-m64"
540 AC_SUBST(PST3CFLAGS)
541 AC_MSG_NOTICE([using 64bit pst3])
542 else
543 AC_MSG_NOTICE([using 32bit pst3])
544 fi
545 EXTRAS_ROOT="$EXTRAS_ROOT pst3"
546
547dnl Removing this for the moment - Ton
515dnl Using /usr/ucb/ps on Solaris systems, to avoid truncation 548dnl Using /usr/ucb/ps on Solaris systems, to avoid truncation
516dnl Limitation that command name is not available 549dnl Limitation that command name is not available
517elif test "$ac_cv_uname_s" = "SunOS" && /usr/ucb/ps -alxwwn 2>/dev/null | \ 550dnl elif test "$ac_cv_uname_s" = "SunOS" && /usr/ucb/ps -alxwwn 2>/dev/null | \
518 egrep -i ["^ *F +UID +PID +PPID +%C +PRI +NI +SZ +RSS +WCHAN +S +TT +TIME +COMMAND"] > /dev/null 551dnl egrep -i ["^ *F +UID +PID +PPID +%C +PRI +NI +SZ +RSS +WCHAN +S +TT +TIME +COMMAND"] > /dev/null
519then 552dnl then
520 ac_cv_ps_varlist="[&procuid,&procpid,&procppid,&procpcpu,&procvsz,&procrss,procstat,&pos]" 553dnl ac_cv_ps_varlist="[&procuid,&procpid,&procppid,&procpcpu,&procvsz,&procrss,procstat,&pos]"
521 ac_cv_ps_command="/usr/ucb/ps -alxwwn" 554dnl ac_cv_ps_command="/usr/ucb/ps -alxwwn"
522 ac_cv_ps_format=["%*s %d %d %d %d %*d %*d %d %d%*[ 0123456789abcdef]%[OSRZT]%*s %*s %n"] 555dnl ac_cv_ps_format=["%*s %d %d %d %d %*d %*d %d %d%*[ 0123456789abcdef]%[OSRZT]%*s %*s %n"]
523 ac_cv_ps_cols=8 556dnl ac_cv_ps_cols=8
524 AC_MSG_RESULT([$ac_cv_ps_command]) 557dnl AC_MSG_RESULT([$ac_cv_ps_command])
525 558
526dnl Some gnu/linux systems (debian for one) don't like -axwo and need axwo. 559dnl Some gnu/linux systems (debian for one) don't like -axwo and need axwo.
527dnl so test for this first... 560dnl so test for this first...