summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 9 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 7e8c810..401bc63 100644
--- a/configure.in
+++ b/configure.in
@@ -1,19 +1,17 @@
1dnl Process this file with autoconf to produce a configure script. 1dnl Process this file with autoconf to produce a configure script.
2AC_PREREQ(2.59) 2AC_PREREQ(2.59)
3AC_INIT(nagios-plugins,1.5) 3AC_INIT(monitoring-plugins,1.5)
4AC_CONFIG_SRCDIR(NPTest.pm) 4AC_CONFIG_SRCDIR(NPTest.pm)
5AC_CONFIG_FILES([gl/Makefile 5AC_CONFIG_FILES([gl/Makefile
6 nagios-plugins.spec]) 6 monitoring-plugins.spec])
7AC_CONFIG_AUX_DIR(build-aux) 7AC_CONFIG_AUX_DIR(build-aux)
8AM_INIT_AUTOMAKE([1.8.3]) 8AM_INIT_AUTOMAKE([1.8.3])
9AM_CONFIG_HEADER(config.h) 9AC_CONFIG_HEADERS([config.h])
10AC_CANONICAL_HOST 10AC_CANONICAL_HOST
11 11
12RELEASE=1 12RELEASE=1
13AC_SUBST(RELEASE) 13AC_SUBST(RELEASE)
14 14
15AC_PREFIX_DEFAULT(/usr/local/nagios)
16
17dnl Deprecated configure options 15dnl Deprecated configure options
18 16
19 17
@@ -58,10 +56,10 @@ AC_SUBST(PLUGIN_TEST)dnl
58SCRIPT_TEST=`echo $srcdir/plugins-scripts/t/*.t|sed -e 's,\.*/plugins-scripts/,,g'` 56SCRIPT_TEST=`echo $srcdir/plugins-scripts/t/*.t|sed -e 's,\.*/plugins-scripts/,,g'`
59AC_SUBST(SCRIPT_TEST)dnl 57AC_SUBST(SCRIPT_TEST)dnl
60 58
61WARRANTY="The nagios plugins come with ABSOLUTELY NO WARRANTY. You may redistribute\ncopies of the plugins under the terms of the GNU General Public License.\nFor more information about these matters, see the file named COPYING.\n" 59WARRANTY="The Monitoring Plugins come with ABSOLUTELY NO WARRANTY. You may redistribute\ncopies of the plugins under the terms of the GNU General Public License.\nFor more information about these matters, see the file named COPYING.\n"
62AC_SUBST(WARRANTY) 60AC_SUBST(WARRANTY)
63 61
64SUPPORT="Send email to nagios-users@lists.sourceforge.net if you have questions\nregarding use of this software. To submit patches or suggest improvements,\nsend email to nagiosplug-devel@lists.sourceforge.net.\nPlease include version information with all correspondence (when possible,\nuse output from the --version option of the plugin itself).\n" 62SUPPORT="Send email to help@monitoring-plugins.org if you have questions regarding use\nof this software. To submit patches or suggest improvements, send email to\ndevel@monitoring-plugins.org. Please include version information with all\ncorrespondence (when possible, use output from the --version option of the\nplugin itself).\n"
65AC_SUBST(SUPPORT) 63AC_SUBST(SUPPORT)
66 64
67dnl CGIURL has changed for Nagios with 1.0 beta 65dnl CGIURL has changed for Nagios with 1.0 beta
@@ -194,7 +192,7 @@ AC_ARG_ENABLE(extra-opts,
194 AC_HELP_STRING([--enable-extra-opts], 192 AC_HELP_STRING([--enable-extra-opts],
195 [Enables parsing of plugins ini config files for extra options (default: no)]), 193 [Enables parsing of plugins ini config files for extra options (default: no)]),
196 [enable_extra_opts=$enableval], 194 [enable_extra_opts=$enableval],
197 [enable_extra_opts=no]) 195 [enable_extra_opts=yes])
198AM_CONDITIONAL([USE_PARSE_INI],[test "$enable_extra_opts" = "yes"]) 196AM_CONDITIONAL([USE_PARSE_INI],[test "$enable_extra_opts" = "yes"])
199if test "$enable_extra_opts" = "yes" ; then 197if test "$enable_extra_opts" = "yes" ; then
200 AC_DEFINE(NP_EXTRA_OPTS,[1],[Enable INI file parsing.]) 198 AC_DEFINE(NP_EXTRA_OPTS,[1],[Enable INI file parsing.])
@@ -648,7 +646,7 @@ elif test "$ac_cv_uname_s" = "SunOS"; then
648 ac_cv_ps_format="%s %d %d %d %d %d %f %s %n" 646 ac_cv_ps_format="%s %d %d %d %d %d %f %s %n"
649 ac_cv_ps_varlist="[procstat,&procuid,&procpid,&procppid,&procvsz,&procrss,&procpcpu,procprog,&pos]" 647 ac_cv_ps_varlist="[procstat,&procuid,&procpid,&procppid,&procvsz,&procrss,&procpcpu,procprog,&pos]"
650 ac_cv_ps_cols=9 648 ac_cv_ps_cols=9
651 AC_MSG_RESULT([using nagios-plugins internal ps command (pst3) for solaris]) 649 AC_MSG_RESULT([using monitoring-plugins internal ps command (pst3) for solaris])
652 if test `isainfo -b` = 64 ; then 650 if test `isainfo -b` = 64 ; then
653 pst3_use_64bit=1 651 pst3_use_64bit=1
654 AC_MSG_NOTICE([using 64bit pst3]) 652 AC_MSG_NOTICE([using 64bit pst3])
@@ -1731,7 +1729,7 @@ AC_ARG_ENABLE(redhat-pthread-workaround,
1731 [ac_cv_enable_redhat_pthread_workaround=test]) 1729 [ac_cv_enable_redhat_pthread_workaround=test])
1732if test "$ac_cv_enable_redhat_pthread_workaround" = "test" ; then 1730if test "$ac_cv_enable_redhat_pthread_workaround" = "test" ; then
1733 if echo $ac_cv_uname_r | egrep "\.EL(smp)?$" >/dev/null 2>&1 ; then 1731 if echo $ac_cv_uname_r | egrep "\.EL(smp)?$" >/dev/null 2>&1 ; then
1734 AC_MSG_NOTICE([See http://nagiosplugins.org/faq/compile/configure_appears_to_hang if this next part takes a long time]) 1732 AC_MSG_NOTICE([See https://www.monitoring-plugins.org/doc/faq/configure-hangs.html if this next part takes a long time])
1735 AC_MSG_CHECKING(for redhat spopen problem) 1733 AC_MSG_CHECKING(for redhat spopen problem)
1736 ( cd config_test && make && make test ) > /dev/null 2>&1 1734 ( cd config_test && make && make test ) > /dev/null 2>&1
1737 if test $? -eq 0 ; then 1735 if test $? -eq 0 ; then
@@ -1748,7 +1746,7 @@ fi
1748dnl Perl modules 1746dnl Perl modules
1749AC_ARG_ENABLE(perl-modules, 1747AC_ARG_ENABLE(perl-modules,
1750 AC_HELP_STRING([--enable-perl-modules], 1748 AC_HELP_STRING([--enable-perl-modules],
1751 [Enables installation of Nagios::Plugin and its dependencies (default: no)]), 1749 [Enables installation of Monitoring::Plugin and its dependencies (default: no)]),
1752 [enable_perl_modules=$enableval], 1750 [enable_perl_modules=$enableval],
1753 [enable_perl_modules=no]) 1751 [enable_perl_modules=no])
1754if test "$enable_perl_modules" = "yes" ; then 1752if test "$enable_perl_modules" = "yes" ; then