summaryrefslogtreecommitdiffstats
path: root/gl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gl/Makefile.am')
-rw-r--r--gl/Makefile.am50
1 files changed, 49 insertions, 1 deletions
diff --git a/gl/Makefile.am b/gl/Makefile.am
index c2e8e5a..54abb4c 100644
--- a/gl/Makefile.am
+++ b/gl/Makefile.am
@@ -21,7 +21,7 @@
21# the same distribution terms as the rest of that program. 21# the same distribution terms as the rest of that program.
22# 22#
23# Generated by gnulib-tool. 23# Generated by gnulib-tool.
24# Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-conditional-dependencies --no-libtool --macro-prefix=gl --no-vc-files base64 crypto/sha1 dirname environ floorf fsusage getaddrinfo gethostname getloadavg getopt-gnu gettext mountlist regex setenv strsep timegm unsetenv vasprintf vsnprintf 24# Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=gl --m4-base=gl/m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-conditional-dependencies --no-libtool --macro-prefix=gl --no-vc-files base64 crypto/sha1 dirname environ floorf fsusage getaddrinfo gethostname getloadavg getopt-gnu gettext idpriv-droptemp mountlist regex setenv strcase strsep timegm unsetenv vasprintf vsnprintf
25 25
26AUTOMAKE_OPTIONS = 1.9.6 gnits subdir-objects 26AUTOMAKE_OPTIONS = 1.9.6 gnits subdir-objects
27 27
@@ -402,6 +402,14 @@ EXTRA_DIST += $(top_srcdir)/build-aux/config.rpath
402 402
403## end gnulib module havelib 403## end gnulib module havelib
404 404
405## begin gnulib module idpriv-droptemp
406
407libgnu_a_SOURCES += idpriv-droptemp.c
408
409EXTRA_DIST += idpriv.h
410
411## end gnulib module idpriv-droptemp
412
405## begin gnulib module inet_ntop 413## begin gnulib module inet_ntop
406 414
407 415
@@ -1536,6 +1544,15 @@ EXTRA_DIST += stdlib.in.h
1536 1544
1537## end gnulib module stdlib 1545## end gnulib module stdlib
1538 1546
1547## begin gnulib module strcase
1548
1549
1550EXTRA_DIST += strcasecmp.c strncasecmp.c
1551
1552EXTRA_libgnu_a_SOURCES += strcasecmp.c strncasecmp.c
1553
1554## end gnulib module strcase
1555
1539## begin gnulib module streq 1556## begin gnulib module streq
1540 1557
1541 1558
@@ -1661,6 +1678,37 @@ EXTRA_DIST += string.in.h
1661 1678
1662## end gnulib module string 1679## end gnulib module string
1663 1680
1681## begin gnulib module strings
1682
1683BUILT_SOURCES += strings.h
1684
1685# We need the following in order to create <strings.h> when the system
1686# doesn't have one that works with the given compiler.
1687strings.h: strings.in.h $(top_builddir)/config.status $(CXXDEFS_H) $(WARN_ON_USE_H) $(ARG_NONNULL_H)
1688 $(AM_V_GEN)rm -f $@-t $@ && \
1689 { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */' && \
1690 sed -e 's|@''GUARD_PREFIX''@|GL|g' \
1691 -e 's|@''HAVE_STRINGS_H''@|$(HAVE_STRINGS_H)|g' \
1692 -e 's|@''INCLUDE_NEXT''@|$(INCLUDE_NEXT)|g' \
1693 -e 's|@''PRAGMA_SYSTEM_HEADER''@|@PRAGMA_SYSTEM_HEADER@|g' \
1694 -e 's|@''PRAGMA_COLUMNS''@|@PRAGMA_COLUMNS@|g' \
1695 -e 's|@''NEXT_STRINGS_H''@|$(NEXT_STRINGS_H)|g' \
1696 -e 's|@''GNULIB_FFS''@|$(GNULIB_FFS)|g' \
1697 -e 's|@''HAVE_FFS''@|$(HAVE_FFS)|g' \
1698 -e 's|@''HAVE_STRCASECMP''@|$(HAVE_STRCASECMP)|g' \
1699 -e 's|@''HAVE_DECL_STRNCASECMP''@|$(HAVE_DECL_STRNCASECMP)|g' \
1700 -e '/definitions of _GL_FUNCDECL_RPL/r $(CXXDEFS_H)' \
1701 -e '/definition of _GL_ARG_NONNULL/r $(ARG_NONNULL_H)' \
1702 -e '/definition of _GL_WARN_ON_USE/r $(WARN_ON_USE_H)' \
1703 < $(srcdir)/strings.in.h; \
1704 } > $@-t && \
1705 mv $@-t $@
1706MOSTLYCLEANFILES += strings.h strings.h-t
1707
1708EXTRA_DIST += strings.in.h
1709
1710## end gnulib module strings
1711
1664## begin gnulib module strndup 1712## begin gnulib module strndup
1665 1713
1666 1714