summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 80f3e62..9cab14a 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -36,3 +36,11 @@ libnagiosplug_a_SOURCES = snprintf.c
36 36
37INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl 37INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl
38 38
39BUILT_SOURCES = $(STDBOOL_H)
40EXTRA_DIST = stdbool_.h
41MOSTLYCLEANFILES = stdbool.h stdbool.ht
42# Create stdbool.h on systems that lack a working one.
43stdbool.h: stdbool_.h
44 sed -e 's/@''HAVE__BOOL''@/$(HAVE__BOOL)/g' $(srcdir)/stdbool_.h > $@t
45 mv $@t $@
46