summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 35663b1..9a8991e 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -13,11 +13,16 @@ libcoreutils_a_SOURCES = \
13 safe-write.c safe-write.h strcase.h xalloc-die.c 13 safe-write.c safe-write.h strcase.h xalloc-die.c
14 14
15# intprops.h required for getloadavg.c 15# intprops.h required for getloadavg.c
16# This needs to be an EXTRA_DIST because the m4s
17# that have AC_LIBSOURCES for intprops.h are not necessary and
18# the getloadavg m4 is an autoconf one, so doesn't
19# know about intprops.h. Confused? You will be!
20EXTRA_DIST = intprops.h
21
16other_coreutils_files = \ 22other_coreutils_files = \
17 error.c error.h \ 23 error.c error.h \
18 fsusage.c \ 24 fsusage.c \
19 getloadavg.c \ 25 getloadavg.c \
20 intprops.h \
21 malloc.c \ 26 malloc.c \
22 mountlist.c \ 27 mountlist.c \
23 realloc.c \ 28 realloc.c \
@@ -43,7 +48,7 @@ print_coreutil_files:
43 48
44# Below are from coreutil's lib/Makefile.am 49# Below are from coreutil's lib/Makefile.am
45BUILT_SOURCES = $(STDBOOL_H) 50BUILT_SOURCES = $(STDBOOL_H)
46EXTRA_DIST = stdbool_.h 51EXTRA_DIST += stdbool_.h
47MOSTLYCLEANFILES = stdbool.h stdbool.ht 52MOSTLYCLEANFILES = stdbool.h stdbool.ht
48# Create stdbool.h on systems that lack a working one. 53# Create stdbool.h on systems that lack a working one.
49stdbool.h: stdbool_.h 54stdbool.h: stdbool_.h