summaryrefslogtreecommitdiffstats
path: root/nagios-plugins.spec
diff options
context:
space:
mode:
Diffstat (limited to 'nagios-plugins.spec')
-rw-r--r--nagios-plugins.spec199
1 files changed, 199 insertions, 0 deletions
diff --git a/nagios-plugins.spec b/nagios-plugins.spec
new file mode 100644
index 0000000..e5997f7
--- /dev/null
+++ b/nagios-plugins.spec
@@ -0,0 +1,199 @@
1%{!?custom:%global custom 0}
2
3%define archive nagios-plugins
4
5%if %custom
6%define name %{archive}-custom
7%else
8%define name %{archive}
9%endif
10
11%define version 1.3.0
12%define release alpha1
13%define source http://nagiosplug.sourceforge.net/src/%{archive}-%{version}-%{release}.tar.gz
14
15Name: %{name}
16Version: %{version}
17Release: %{release}
18Copyright: GPL
19Source: %{source}
20BuildRoot: %{_tmppath}/%{name}-buildroot
21Prefix: %{_prefix}/lib/nagios/plugins
22Packager: Karl DeBisschop <kdebisschop@users.sourceforge.net>
23Vendor: Nagios Plugin Development Group
24%if %custom
25Obsoletes: nagios-plugins nagios-plugins-extras
26%else
27Obsoletes: nagios-plugins-custom
28%endif
29AutoReqProv: no
30Summary: Host/service/network monitoring program plugins for Nagios
31Group: Applications/System
32
33
34%description
35
36Nagios is a program that will monitor hosts and services on your
37network, and to email or page you when a problem arises or is
38resolved. Nagios runs on a unix server as a background or daemon
39process, intermittently running checks on various services that you
40specify. The actual service checks are performed by separate "plugin"
41programs which return the status of the checks to Nagios.
42
43This package contains the basic plugins necessary for use with the
44Nagios package. This package should install cleanly on almost any
45RPM-based system.
46
47
48%package extras
49Summary: Plugins which depend on the presence of other packages
50Group: Applications/System
51
52%description extras
53
54Nagios is a program that will monitor hosts and services on your
55network, and to email or page you when a problem arises or is
56resolved. Nagios runs on a unix server as a background or daemon
57process, intermittently running checks on various services that you
58specify. The actual service checks are performed by separate "plugin"
59programs which return the status of the checks to Nagios.
60
61This package contains plugins which use additional libraries or system
62calls that are not installed on all systems. As a result, most users
63will need to install the '--nodeps' option when invoking `rpm`
64
65
66%prep
67%setup -q -n %{archive}-%{version}-%{release}
68
69
70%build
71CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" ./configure \
72--prefix=%{_prefix}/lib/nagios/plugins \
73--libexecdir=%{_prefix}/lib/nagios/plugins \
74--with-cgiurl=/nagios/cgi-bin
75make
76
77
78%install
79make AM_INSTALL_PROGRAM_FLAGS="" DESTDIR=${RPM_BUILD_ROOT} install
80install -d ${RPM_BUILD_ROOT}/etc/nagios
81install -m 664 command.cfg ${RPM_BUILD_ROOT}/etc/nagios
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86
87%files
88%defattr(-,root,root)
89%config(missingok,noreplace) /etc/nagios/command.cfg
90%doc INSTALL README REQUIREMENTS COPYING ChangeLog command.cfg
91%defattr(775,root,root)
92%dir %{_prefix}/lib/nagios/plugins
93%if %custom
94%{_prefix}/lib/nagios/plugins/*
95%else
96%{_prefix}/lib/nagios/plugins/check_by_ssh
97%{_prefix}/lib/nagios/plugins/check_breeze
98%{_prefix}/lib/nagios/plugins/check_disk
99%{_prefix}/lib/nagios/plugins/check_disk_smb
100%{_prefix}/lib/nagios/plugins/check_dns
101%{_prefix}/lib/nagios/plugins/check_dummy
102%{_prefix}/lib/nagios/plugins/check_flexlm
103%{_prefix}/lib/nagios/plugins/check_ftp
104%{_prefix}/lib/nagios/plugins/check_http
105%{_prefix}/lib/nagios/plugins/check_imap
106%{_prefix}/lib/nagios/plugins/check_ircd
107%{_prefix}/lib/nagios/plugins/check_load
108%{_prefix}/lib/nagios/plugins/check_log
109%{_prefix}/lib/nagios/plugins/check_mrtg
110%{_prefix}/lib/nagios/plugins/check_mrtgtraf
111%{_prefix}/lib/nagios/plugins/check_nagios
112%{_prefix}/lib/nagios/plugins/check_nntp
113%{_prefix}/lib/nagios/plugins/check_ntp
114%{_prefix}/lib/nagios/plugins/check_nwstat
115%{_prefix}/lib/nagios/plugins/check_oracle
116%{_prefix}/lib/nagios/plugins/check_overcr
117%{_prefix}/lib/nagios/plugins/check_ping
118%{_prefix}/lib/nagios/plugins/check_pop
119%{_prefix}/lib/nagios/plugins/check_procs
120%{_prefix}/lib/nagios/plugins/check_real
121%{_prefix}/lib/nagios/plugins/check_rpc
122%{_prefix}/lib/nagios/plugins/check_sensors
123%{_prefix}/lib/nagios/plugins/check_smtp
124%{_prefix}/lib/nagios/plugins/check_ssh
125%{_prefix}/lib/nagios/plugins/check_swap
126%{_prefix}/lib/nagios/plugins/check_tcp
127%{_prefix}/lib/nagios/plugins/check_time
128%{_prefix}/lib/nagios/plugins/check_udp
129%{_prefix}/lib/nagios/plugins/check_ups
130%{_prefix}/lib/nagios/plugins/check_users
131%{_prefix}/lib/nagios/plugins/check_vsz
132%{_prefix}/lib/nagios/plugins/check_wave
133%{_prefix}/lib/nagios/plugins/utils.pm
134%{_prefix}/lib/nagios/plugins/utils.sh
135%{_prefix}/lib/nagios/plugins/urlize
136%endif
137
138%if ! %custom
139%files extras
140%defattr(775,root,root)
141%{_prefix}/lib/nagios/plugins/check_fping
142%{_prefix}/lib/nagios/plugins/check_game
143%{_prefix}/lib/nagios/plugins/check_ldap
144%{_prefix}/lib/nagios/plugins/check_mysql
145%{_prefix}/lib/nagios/plugins/check_pgsql
146%{_prefix}/lib/nagios/plugins/check_radius
147%{_prefix}/lib/nagios/plugins/check_snmp
148%{_prefix}/lib/nagios/plugins/check_hpjd
149
150%endif
151
152%changelog
153* Wed Jan 17 2001 Karl DeBisschop <karl@debisschop.net> (1.2.9-1)
154- switch from /usr/libexec to /usr/lib because FHS has no libexec
155- use 'custom' macro define to merge with nagios-plugins-custom spec
156- add check_game to extras
157
158* Mon Jun 26 2000 Karl DeBisschop <karl@debisschop.net>
159- Release 1.2.8-4 (check_ping bug fix)
160- use bzip2 insted of gzip for mandrake compatibility
161
162* Thu Jun 22 2000 Karl DeBisschop <karl@debisschop.net>
163- Release 1.2.8-3 (bug fixes)
164- Add macros to spec where possible
165
166* Fri Jun 16 2000 Karl DeBisschop <karl@debisschop.net>
167- Release 1.2.8-2 (bug fixes)
168
169* Fri Jun 09 2000 Karl DeBisschop <karl@debisschop.net>
170- Release to 1.2.8
171
172* Wed Jun 07 2000 Karl DeBisschop <karl@debisschop.net>
173- Upgrade to 1.2.8pre7
174
175* Sat Jun 03 2000 Karl DeBisschop <karl@debisschop.net>
176- Upgraded to 1.2.8pre5
177- use RPM_OPT_FALGS to set compiler options
178- cahneg group to Applications/System
179
180* Fri May 19 2000 Karl DeBisschop <karl@debisschop.net>
181- Upgraded to 1.2.8pre3 (release-3)
182
183* Mon Mar 20 2000 Karl DeBisschop <karl@debisschop.net>
184- Upgraded to 1.2.8b2
185
186* Tue Dec 14 1999 Adam Jacob <adam@cybertrails.com> (1.2.7-1cvs)
187- Upgraded package from 1.2.6 to 1.2.7 from the latest CVS code
188- Modified SPEC file to contain the proper build_root stuff. :)
189
190* Tue Oct 19 1999 Mike McHenry <mmchen@minn.net> (1.2.6)
191- Upgraded package from 1.2.4 to 1.2.6
192- Resolved dependancy issue with libpq.so
193- Added support for check_fping
194
195* Fri Sep 03 1999 Mike McHenry <mmchen@minn.net> (1.2.4)
196- Upgraded package from 1.2.2 to 1.2.4
197
198* Mon Aug 16 1999 Mike McHenry <mmchen@minn.net> (1.2.2)
199- First RPM build (1.2.2)