summaryrefslogtreecommitdiffstats
path: root/plugins-root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins-root/Makefile.am')
-rw-r--r--plugins-root/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/plugins-root/Makefile.am b/plugins-root/Makefile.am
index 2184053..b5f5519 100644
--- a/plugins-root/Makefile.am
+++ b/plugins-root/Makefile.am
@@ -13,7 +13,7 @@ AM_CFLAGS = -DNP_VERSION='"$(NP_VERSION)"'
13 13
14VPATH = $(top_srcdir) $(top_srcdir)/lib $(top_srcdir)/plugins $(top_srcdir)/plugins/t $(srcdir) 14VPATH = $(top_srcdir) $(top_srcdir)/lib $(top_srcdir)/plugins $(top_srcdir)/plugins/t $(srcdir)
15 15
16INCLUDES = -I.. -I$(top_srcdir)/lib -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins @SSLINCLUDE@ 16AM_CPPFLAGS = -I.. -I$(top_srcdir)/lib -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins @SSLINCLUDE@
17 17
18localedir = $(datadir)/locale 18localedir = $(datadir)/locale
19DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@ 19DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
@@ -79,9 +79,12 @@ install-exec-local: $(noinst_PROGRAMS)
79# the actual targets 79# the actual targets
80check_dhcp_LDADD = @LTLIBINTL@ $(NETLIBS) 80check_dhcp_LDADD = @LTLIBINTL@ $(NETLIBS)
81check_icmp_LDADD = @LTLIBINTL@ $(NETLIBS) $(SOCKETLIBS) 81check_icmp_LDADD = @LTLIBINTL@ $(NETLIBS) $(SOCKETLIBS)
82
82# -m64 needed at compiler and linker phase 83# -m64 needed at compiler and linker phase
83pst3_CFLAGS = @PST3CFLAGS@ 84pst3_CFLAGS = @PST3CFLAGS@
84pst3_LDFLAGS = @PST3CFLAGS@ 85pst3_LDFLAGS = @PST3CFLAGS@
86# pst3 must not use nagiosplug/gnulib includes!
87pst3_CPPFLAGS =
85 88
86check_dhcp_DEPENDENCIES = check_dhcp.c $(NETOBJS) $(DEPLIBS) 89check_dhcp_DEPENDENCIES = check_dhcp.c $(NETOBJS) $(DEPLIBS)
87check_icmp_DEPENDENCIES = check_icmp.c $(NETOBJS) 90check_icmp_DEPENDENCIES = check_icmp.c $(NETOBJS)