summaryrefslogtreecommitdiffstats
path: root/plugins-scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins-scripts/Makefile.am')
-rw-r--r--plugins-scripts/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/plugins-scripts/Makefile.am b/plugins-scripts/Makefile.am
new file mode 100644
index 0000000..4bdf717
--- /dev/null
+++ b/plugins-scripts/Makefile.am
@@ -0,0 +1,30 @@
1## Process this file with automake to produce Makefile.in
2
3SUFFIXES = .pl .sh
4
5VPATH=$(top_srcdir) $(top_srcdir)/plugins-scripts $(top_srcdir)/plugins-scripts/t
6
7libexec_SCRIPTS = check_breeze check_disk_smb check_flexlm check_ircd \
8 check_log check_ntp check_oracle check_rpc check_sensors check_wave \
9 utils.sh utils.pm
10
11EXTRA_DIST=check_breeze.pl check_disk_smb.pl check_flexlm.pl check_ircd.pl \
12 check_log.sh check_ntp.pl check_oracle.sh check_rpc.pl check_sensors.sh \
13 check_wave.pl utils.sh.in utils.pm.in t
14
15TESTS_ENVIRONMENT=perl -I $(top_builddir) -I $(top_srcdir)
16
17TESTS = @SCRIPT_TEST@
18
19test:
20 perl -I $(top_builddir) -I $(top_srcdir) ../test.pl
21
22CLEANFILES=$(libexec_SCRIPTS)
23
24.pl :
25 $(AWK) -f ./subst $< > $@
26 chmod +x $@
27
28.sh :
29 $(AWK) -f ./subst $< > $@
30 chmod +x $@