[Nagiosplug-devel] Nagios plugins CPAN-like archive

Andreas Ericsson ae at op5.se
Tue Jul 12 18:29:09 CEST 2005

sean finney wrote:
> On Tue, Jul 12, 2005 at 05:17:41PM +0200, Andreas Ericsson wrote:
>>This shouldn't be a problem, considering the fact that the code quality 
>>of todays official plugins isn't exactly stellar.
> perhaps this may be true, but this is something i'm actively working on
> making less true.   i also think your standards are a more critical than
> most peoples'.

That's neither an unmixed blessing nor a very big problem. I also think 
it's quite true. It's also one of the main reasons I had to fork the 
plugins and keep a separate branch of them. The fixes amounted to too 
many too fast for me to be able to handle it without commit access to 
some sort of SCM.

>  but more importantly, i look at the quality of what's
> in the official plugins, and look at what's in contrib, and i kind of
> plot an imaginary line in my mind and imagine that introducing such
> an archive would take things even further out.
>>The official plugins doesn't HAVE a namespace, unless you count the 
>>"my_" prefix, which is sort of restricted for personal use by general 
>>agreement. I like the np_ you added in front of np_connect() though, so 
>>that could be the seed to one.
> i was referring not so much to the API (though yes, the future internal
> API should have a common naming scheme) as the names of the plugins
> themselves.  

You mean the check_ prefix? It's not a naming standard per se, as it's 
totally unrelated to the nagiosplug project (or nagios for that matter), 
except by coincidence. If the prefix was np_ or nplg_ (snmpget, 
snmpwalk, snmpgetbulk et al) you might have better luck, but as it 
stands I think your chances are pretty slim of making other people 
adhere to it.

Andreas Ericsson                   andreas.ericsson at op5.se
OP5 AB                             www.op5.se
Lead Developer

More information about the Devel mailing list