np_ function prefix

William Leibzon william at
Sun Jan 26 08:17:04 CET 2014

On Thu, Jan 23, 2014 at 4:18 AM, Holger Weiß <holger at> wrote:
> * William Leibzon <william at> [2014-01-22 18:45]:
>> Do we want to keep np_ prefix that many functions in the source code use?
> We haven't really decided on this one yet.  Do you think we should?

I'm not sure that's why I opened the topic up. Seems like eventually
it'd be best to rename but its not a big issue at the moment. Maybe
seen how much patch exchange there would be between monitoring-plugins
and nagios-plugins and who does patches and how and then decide.

>> One of the options could be to change this to mp_ which is not
>> difficult for nagios plugins source code itself but there are, I
>> think, external plugins that link to and use these nagios plugin
>> functions too.
> Yes.  That's never been supported, but of course there might be plugins
> doing just that regardless.
> The other downside is that such a change makes it a bit harder to
> exchange patches with the Nagios Enterprises team.

More information about the Devel mailing list