summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorSven Nierlein <sven@nierlein.de>2014-01-19 23:54:34 (GMT)
committerSven Nierlein <sven@nierlein.de>2014-01-19 23:54:34 (GMT)
commitb418181dfe80dd75169b6e8a619ac1932155dea2 (patch)
treecad9c0ae0eae8e800cfff60555ead06ad33c6856 /Makefile.PL
parent1cd8d1c52cbd47121f344c4074aec84653f412ce (diff)
downloadmonitoring-plugin-perl-b418181dfe80dd75169b6e8a619ac1932155dea2.tar.gz
renamed module into Monitoring::Plugin
since the complete monitoring team has been renamed, we also rename this module. Signed-off-by: Sven Nierlein <sven@nierlein.de>
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL45
1 files changed, 23 insertions, 22 deletions
diff --git a/Makefile.PL b/Makefile.PL
index c043edb..d1f0c2a 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,22 +1,23 @@
1use 5.006; 1use inc::Module::Install;
2use ExtUtils::MakeMaker; 2
3# See lib/ExtUtils/MakeMaker.pm for details of how to influence 3name 'Monitoring-Plugin';
4# the contents of the Makefile that is written. 4all_from 'lib/Monitoring/Plugin/Functions.pm';
5WriteMakefile( 5author q{Monitoring Plugin Team <devel@monitoring-plugins.org>};
6 NAME => 'Nagios::Plugin', 6license 'perl';
7 VERSION_FROM => 'lib/Nagios/Plugin/Functions.pm', # finds $VERSION 7repository 'https://github.com/monitoring-plugins/monitoring-plugin-perl';
8 PREREQ_PM => { 8
9 Params::Validate => 0, 9requires 'Params::Validate' => 0;
10 Class::Accessor => 0, 10requires 'Class::Accessor' => 0;
11 Test::More => 0.62, 11requires 'Carp' => 0;
12 Carp => 0, 12requires 'Config::Tiny' => 0;
13 Config::Tiny => 0, 13requires 'File::Spec' => 0;
14 File::Spec => 0, 14requires 'File::Basename' => 0;
15 File::Basename => 0, 15requires 'IO::File' => 0;
16 IO::File => 0, 16requires 'Math::Calc::Units' => 0; # used in M::P::Performance
17 Math::Calc::Units => 0, # used in N::P::Performance 17
18 }, # e.g., Module::Name => 1.1 18
19 ($] >= 5.005 ? ## Add these new keywords supported since 5.005 19build_requires 'Test::More' => 0.62;
20 (ABSTRACT_FROM => 'lib/Nagios/Plugin.pm', # retrieve abstract from module 20
21 AUTHOR => 'Nagios Plugin Development Team <nagiosplug-devel@lists.sourceforge.net>') : ()), 21auto_install;
22); 22
23WriteAll;