summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2007-12-12 01:27:48 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2007-12-12 01:27:48 (GMT)
commit151531173bd50d66548effa50ef7393a8c680513 (patch)
tree7812c912217e191931e71c6138cf694916c914d2 /Makefile.am
parent27627ee6c20d57096ee9364b144f59180a96c3ac (diff)
downloadmonitoring-plugins-151531173bd50d66548effa50ef7393a8c680513.tar.gz
Run tinderbox builds in a test debug mode using "make test-debug"
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1866 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 701c56c..416ef62 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,11 +22,11 @@ dist-hook:
22install-root: 22install-root:
23 cd plugins-root && $(MAKE) $@ 23 cd plugins-root && $(MAKE) $@
24 24
25test: 25test test-debug:
26 cd lib && $(MAKE) test 26 cd lib && $(MAKE) $@
27 if test "$(PERLMODS_DIR)" != ""; then cd perlmods && $(MAKE) test; fi 27 if test "$(PERLMODS_DIR)" != ""; then cd perlmods && $(MAKE) $@; fi
28 cd plugins && $(MAKE) test 28 cd plugins && $(MAKE) $@
29 cd plugins-scripts && $(MAKE) test 29 cd plugins-scripts && $(MAKE) $@
30 30
31nagios-plugins.spec: nagios-plugins.spec.in 31nagios-plugins.spec: nagios-plugins.spec.in
32 sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;s/^%%{requires}$$//" $? > $@ 32 sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;s/^%%{requires}$$//" $? > $@