summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeremy T. Bouse <undrgrid@users.sourceforge.net>2003-03-23 07:01:20 (GMT)
committerJeremy T. Bouse <undrgrid@users.sourceforge.net>2003-03-23 07:01:20 (GMT)
commit739ea144d276ca475730d0c928ed9fd82f3cba03 (patch)
tree58fad2d7ab1427e06150c53cdcb3e41a5d03f9f5 /Makefile.am
parentc9d73535b59fef3056c65c3be6e1e18e4509629a (diff)
downloadmonitoring-plugins-739ea144d276ca475730d0c928ed9fd82f3cba03.tar.gz
Solaris package build system
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@449 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 9 insertions, 23 deletions
diff --git a/Makefile.am b/Makefile.am
index 3318259..8cc1514 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,7 @@
3SUBDIRS = lib plugins plugins-scripts 3SUBDIRS = lib plugins plugins-scripts
4 4
5EXTRA_DIST = CODING FAQ LEGAL REQUIREMENTS SUPPORT \ 5EXTRA_DIST = CODING FAQ LEGAL REQUIREMENTS SUPPORT \
6 Helper.pm contrib nagios-plugins.spec.in 6 Helper.pm contrib pkg nagios-plugins.spec.in
7 7
8ACLOCAL_AMFLAGS = -I lib 8ACLOCAL_AMFLAGS = -I lib
9 9
@@ -18,31 +18,17 @@ nagios-plugins.spec: nagios-plugins.spec.in
18 sed "s/%%{VER}/${VER}/;s/%%{REL}/${REL}/;" $? > $@ 18 sed "s/%%{VER}/${VER}/;s/%%{REL}/${REL}/;" $? > $@
19 19
20# Solaris pkgmk 20# Solaris pkgmk
21PACKDIR=build-pkg 21BUILDDIR=`pwd`/build-solaris
22PACKDIR=`pwd`/build-pkg
22VERSION=@PACKAGE_VERSION@ 23VERSION=@PACKAGE_VERSION@
23 24
24Prototype: 25solpkg:
26 if [ ! -d $(BUILDDIR) ] ; then mkdir $(BUILDDIR); fi
25 if [ ! -d $(PACKDIR) ] ; then mkdir $(PACKDIR); fi 27 if [ ! -d $(PACKDIR) ] ; then mkdir $(PACKDIR); fi
26 cd build-solaris
27 $(MAKE) all 28 $(MAKE) all
28 $(MAKE) DESTDIR=../$(PACKDIR) install 29 $(MAKE) DESTDIR=$(BUILDDIR) install
29 cd .. 30 $(INSTALL) pkg/solaris/pkginfo $(BUILDDIR)
30 echo i pkginfo> Prototype 31 $(cd $(BUILDDIR) && `pwd`/pkg/solaris/solpkg $(PACKDIR))
31 if [ -f checkinstall ] ; then echo i checkinstall>> Prototype; fi
32 if [ -f preinstall ] ; then echo i preinstall>> Prototype; fi
33 if [ -f postinstall ] ; then echo i postinstall>> Prototype; fi
34 pkgproto $(PACKDIR)=/ | sed -e "s|$(LOGNAME) $(GROUP)$$|root root|" | egrep -v "(s|d) none (/|/etc|/var|/usr|/usr/local) " >> Prototype
35
36pkgmap: ../Prototype
37 mkdir -p $(PACKDIR)/nagiosp
38 cd $(PACKDIR)/nagiosp
39 pkgmk -o -r / -f ../Prototype -d $(PACKDIR) nagiosp
40 cd ..
41
42nagios.SPARC.pkg.tar.gz: pkgmap
43 cd $(PACKDIR) && tar -cf - nagiosp | gzip -9 -c > ../nagiosp.SPARC.pkg.tar.gz
44
45pkgset: nagiosp.SPARC.pkg.tar.gz
46 32
47pkgclean: 33pkgclean:
48 rm -rf Prototype nagiosp.SPARC.pkg.tar.gz 34 rm -rf $(BUILDDIR) $(PACKDIR)