summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarl DeBisschop <kdebisschop@users.sourceforge.net>2002-10-25 02:31:03 (GMT)
committerKarl DeBisschop <kdebisschop@users.sourceforge.net>2002-10-25 02:31:03 (GMT)
commit898da8c89aea9f1dd55f4a569799d9daa51407d1 (patch)
treeccdf1a888db1f2bcbe391066896a4a6526618bb4 /Makefile.am
parent6361f796172f240f5ecb2c21a60511634bbc6d47 (diff)
downloadmonitoring-plugins-898da8c89aea9f1dd55f4a569799d9daa51407d1.tar.gz
include getloadavg sources, add some Solaris pkg build support
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@158 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 31 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index af0e86e..9e0415e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,7 @@
3SUBDIRS = plugins plugins-scripts 3SUBDIRS = plugins plugins-scripts
4 4
5EXTRA_DIST = REQUIREMENTS acconfig.h subst.in subst.sh Helper.pm \ 5EXTRA_DIST = REQUIREMENTS acconfig.h subst.in subst.sh Helper.pm \
6contrib nagios-plugins.spec.in 6contrib nagios-plugins.spec.in getloadavg.m4
7 7
8dist-hook: 8dist-hook:
9 sed "s/PACKAGE_VERSION/@PACKAGE_VERSION@/;s/PACKAGE_RELEASE/@PACKAGE_RELEASE@/;" $(srcdir)/nagios-plugins.spec.in > $(distdir)/nagios-plugins.spec 9 sed "s/PACKAGE_VERSION/@PACKAGE_VERSION@/;s/PACKAGE_RELEASE/@PACKAGE_RELEASE@/;" $(srcdir)/nagios-plugins.spec.in > $(distdir)/nagios-plugins.spec
@@ -11,3 +11,33 @@ dist-hook:
11test: 11test:
12 cd plugins; $(MAKE) test 12 cd plugins; $(MAKE) test
13 cd plugins-scripts; $(MAKE) test 13 cd plugins-scripts; $(MAKE) test
14
15# Solaris pkgmk
16PACKDIR=build-pkg
17VERSION=@PACKAGE_VERSION@
18
19Prototype:
20 if [ ! -d $(PACKDIR) ] ; then mkdir $(PACKDIR); fi
21 cd build-solaris
22 $(MAKE) all
23 $(MAKE) DESTDIR=../$(PACKDIR) install
24 cd ..
25 echo i pkginfo> Prototype
26 if [ -f checkinstall ] ; then echo i checkinstall>> Prototype; fi
27 if [ -f preinstall ] ; then echo i preinstall>> Prototype; fi
28 if [ -f postinstall ] ; then echo i postinstall>> Prototype; fi
29 pkgproto $(PACKDIR)=/ | sed -e "s|$(LOGNAME) $(GROUP)$$|root root|" | egrep -v "(s|d) none (/|/etc|/var|/usr|/usr/local) " >> Prototype
30
31pkgmap: ../Prototype
32 mkdir -p $(PACKDIR)/nagiosp
33 cd $(PACKDIR)/nagiosp
34 pkgmk -o -r / -f ../Prototype -d $(PACKDIR) nagiosp
35 cd ..
36
37nagios.SPARC.pkg.tar.gz: pkgmap
38 cd $(PACKDIR) && tar -cf - nagiosp | gzip -9 -c > ../nagiosp.SPARC.pkg.tar.gz
39
40pkgset: nagiosp.SPARC.pkg.tar.gz
41
42pkgclean:
43 rm -rf Prototype nagiosp.SPARC.pkg.tar.gz