summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Stanley <estanley@nagios.com>2012-04-06 15:18:47 (GMT)
committerEric Stanley <estanley@nagios.com>2012-04-06 15:18:47 (GMT)
commit9cdd9a149c1c0213802d15cc204d60b3199a9653 (patch)
tree55175aac0d91119e68de7c4d42e194cff453d988 /Makefile.am
parent4011599466b8247ced0b6400b72e16620636d0fc (diff)
downloadmonitoring-plugins-9cdd9a149c1c0213802d15cc204d60b3199a9653.tar.gz
Updated to support compiling and building RPM on AIX.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 1 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index ce6ae6a..cbca5d7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,7 +16,7 @@ localedir = $(datadir)/locale
16DEFS = -DLOCALEDIR=\"$(localedir)\" 16DEFS = -DLOCALEDIR=\"$(localedir)\"
17 17
18dist-hook: 18dist-hook:
19 make THANKS nagios-plugins.spec pkg/fedora/nagios-plugins.spec 19 $(MAKE) THANKS
20 echo ${VERSION} >$(distdir)/release 20 echo ${VERSION} >$(distdir)/release
21 21
22install-root: 22install-root:
@@ -28,13 +28,6 @@ test test-debug:
28 cd plugins && $(MAKE) $@ 28 cd plugins && $(MAKE) $@
29 cd plugins-scripts && $(MAKE) $@ 29 cd plugins-scripts && $(MAKE) $@
30 30
31nagios-plugins.spec: nagios-plugins.spec.in
32 sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;s/^%%{requires}$$//" $? > $@
33
34pkg/fedora/nagios-plugins.spec: nagios-plugins.spec.in
35 $(top_srcdir)/mkinstalldirs pkg/fedora
36 sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;/^# Requires$$/r $(top_srcdir)/pkg/fedora/requires" $? > $@
37
38# Solaris pkgmk 31# Solaris pkgmk
39BUILDDIR = build-solaris 32BUILDDIR = build-solaris
40PACKDIR = build-pkg 33PACKDIR = build-pkg