summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarl DeBisschop <kdebisschop@users.sourceforge.net>2004-03-02 06:17:53 (GMT)
committerKarl DeBisschop <kdebisschop@users.sourceforge.net>2004-03-02 06:17:53 (GMT)
commite2e3017e7af883503eb42d28ba69a90274a016d2 (patch)
treef6c9013688a66e50e0b83449bbfb67c445b17abd /Makefile.am
parent439bf19ea97fd72f058ea2124b39fd4b920fd8b2 (diff)
downloadmonitoring-plugins-e2e3017e7af883503eb42d28ba69a90274a016d2.tar.gz
make specfile into a template which can generate a generic spec plus specs suitable for various repositories
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@837 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f427a11..2177840 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,14 +12,18 @@ localedir = $(datadir)/locale
12DEFS = -DLOCALEDIR=\"$(localedir)\" 12DEFS = -DLOCALEDIR=\"$(localedir)\"
13 13
14dist-hook: 14dist-hook:
15 make THANKS nagios-plugins.spec 15 make THANKS nagios-plugins.spec pkg/fedora/nagios-plugins.spec
16 16
17test: 17test:
18 cd plugins; $(MAKE) test 18 cd plugins; $(MAKE) test
19 cd plugins-scripts; $(MAKE) test 19 cd plugins-scripts; $(MAKE) test
20 20
21nagios-plugins.spec: nagios-plugins.spec.in 21nagios-plugins.spec: nagios-plugins.spec.in
22 sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;" $? > $@ 22 sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;s/^%%{requires}$$//" $? > $@
23
24pkg/fedora/nagios-plugins.spec: nagios-plugins.spec.in
25 $(top_srcdir)/mkinstalldirs pkg/fedora
26 sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;/^# Requires$$/r $(top_srcdir)/pkg/fedora/requires" $? > $@
23 27
24# Solaris pkgmk 28# Solaris pkgmk
25BUILDDIR = build-solaris 29BUILDDIR = build-solaris