summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarl DeBisschop <kdebisschop@users.sourceforge.net>2003-09-04 06:43:38 (GMT)
committerKarl DeBisschop <kdebisschop@users.sourceforge.net>2003-09-04 06:43:38 (GMT)
commitfee4763db44ef71dff247d97d28ec4f670acbed0 (patch)
tree3808fa3a1436b666bb87e52d40d34fb396270c1e /Makefile.am
parent699d1f4188ad430fcbea445fe39bfb536fd731e5 (diff)
downloadmonitoring-plugins-fee4763db44ef71dff247d97d28ec4f670acbed0.tar.gz
change so make-dist works in subdirs
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@715 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 50c7edd..7fe5447 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,7 @@ SUBDIRS = intl lib plugins plugins-scripts po
4 4
5EXTRA_DIST = config.rpath \ 5EXTRA_DIST = config.rpath \
6 ABOUT-NLS CODING FAQ LEGAL REQUIREMENTS SUPPORT THANKS \ 6 ABOUT-NLS CODING FAQ LEGAL REQUIREMENTS SUPPORT THANKS \
7 Helper.pm contrib pkg nagios-plugins.spec.in 7 Helper.pm contrib pkg nagios-plugins.spec
8 8
9ACLOCAL_AMFLAGS = -I lib 9ACLOCAL_AMFLAGS = -I lib
10 10
@@ -12,7 +12,7 @@ localedir = $(datadir)/locale
12DEFS = -DLOCALEDIR=\"$(localedir)\" 12DEFS = -DLOCALEDIR=\"$(localedir)\"
13 13
14dist-hook: 14dist-hook:
15 sed "s/%%{VERSION}/${VERSION}/;s/%%{RELEASE}/${RELEASE}/;" $(srcdir)/nagios-plugins.spec.in > $(distdir)/nagios-plugins.spec 15 make THANKS nagios-plugins.spec
16 16
17test: 17test:
18 cd plugins; $(MAKE) test 18 cd plugins; $(MAKE) test
@@ -34,8 +34,12 @@ solpkg:
34 $(INSTALL) pkg/solaris/pkginfo $(BUILDDIR) 34 $(INSTALL) pkg/solaris/pkginfo $(BUILDDIR)
35 cd $(BUILDDIR) && $(PERL) ../$(PKGSCRIPT) ../$(PACKDIR) 35 cd $(BUILDDIR) && $(PERL) ../$(PKGSCRIPT) ../$(PACKDIR)
36 36
37THANKS: THANKS.in AUTHORS 37THANKS: AUTHORS
38 perl -e ' while (<>) { print STDERR "Duplicate: $$_",$$/ if ($$a{$$_}) ; $$a{$$_}++}; print sort by_last_field (keys %a); sub by_last_field { ($$a1) = $$a =~ /\s(\w+)$$/; ($$b1) = $$b =~ /\s(\w+)$$/; $$a1 cmp $$b1}' AUTHORS | cat THANKS.in - > $@ 38 @echo "This software is brought to you by the Nagios Plugins Development Team. However," > $@
39 @echo "there have been many contributors to this project. Everyone below has helped in " >> $@
40 @echo "raising bug reports, creating patches or contributing new plugins." >> $@
41 @echo "" >> $@
42 perl -e ' while (<>) { print STDERR "Duplicate: $$_",$$/ if ($$a{$$_}) ; $$a{$$_}++}; print sort by_last_field (keys %a); sub by_last_field { ($$a1) = $$a =~ /\s(\w+)$$/; ($$b1) = $$b =~ /\s(\w+)$$/; $$a1 cmp $$b1}' $? >> $@
39 43
40pkgclean: 44pkgclean:
41 rm -rf $(BUILDDIR) $(PACKDIR) 45 rm -rf $(BUILDDIR) $(PACKDIR)