summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorvagrant <vagrant@debiantesting-64>2016-11-13 19:39:46 (GMT)
committerSven Nierlein <sven@nierlein.de>2016-11-13 21:14:02 (GMT)
commitfe1c4bb0e5ea3632d608a6b8b7e51d580856d833 (patch)
tree5fceabfc6f53b2bf7505bba099fa75d6cc8159bc /configure.ac
parent2f845e9ebc2b7bcf6472e0191752215d351e4e7c (diff)
downloadmonitoring-plugins-fe1c4bb0e5ea3632d608a6b8b7e51d580856d833.tar.gz
add openssl 1.1 supportrefs/pull/1443/head
changes: - CRYPTO_lock detection replaced in configure.ac. We don't use that function anywhere, so just replace it with the suggested one from https://wiki.openssl.org/index.php/Library_Initialization#Autoconf - OPENSSL_NO_SSL2 is no longer defined while ssl2 is not included. Set it ourself using the suggested openssl 1.1 version check from https://wiki.openssl.org/index.php/1.1_API_Changes#Backward_compatibility - openssl 1.1 sends a sigpipe if the connection is still open when calling SSL_shutdown(), so move the close before the shutdown. Signed-off-by: Sven Nierlein <sven@nierlein.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0a554af..5ef56f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -493,15 +493,15 @@ if ! test x"$with_openssl" = x"no"; then
493 dnl Check for crypto lib 493 dnl Check for crypto lib
494 _SAVEDLIBS="$LIBS" 494 _SAVEDLIBS="$LIBS"
495 LIBS="-L${with_openssl}/lib" 495 LIBS="-L${with_openssl}/lib"
496 AC_CHECK_LIB(crypto,CRYPTO_lock) 496 AC_CHECK_LIB(crypto,CRYPTO_new_ex_data)
497 if test "$ac_cv_lib_crypto_CRYPTO_lock" = "yes"; then 497 if test "$ac_cv_lib_crypto_CRYPTO_new_ex_data" = "yes"; then
498 dnl Check for SSL lib 498 dnl Check for SSL lib
499 AC_CHECK_LIB(ssl,main, SSLLIBS="-lssl -lcrypto",,-lcrypto) 499 AC_CHECK_LIB(ssl,main, SSLLIBS="-lssl -lcrypto",,-lcrypto)
500 fi 500 fi
501 LIBS="$_SAVEDLIBS" 501 LIBS="$_SAVEDLIBS"
502 502
503 dnl test headers and libs to decide whether check_http should use SSL 503 dnl test headers and libs to decide whether check_http should use SSL
504 if test "$ac_cv_lib_crypto_CRYPTO_lock" = "yes"; then 504 if test "$ac_cv_lib_crypto_CRYPTO_new_ex_data" = "yes"; then
505 if test "$ac_cv_lib_ssl_main" = "yes"; then 505 if test "$ac_cv_lib_ssl_main" = "yes"; then
506 if test "$FOUNDINCLUDE" = "yes"; then 506 if test "$FOUNDINCLUDE" = "yes"; then
507 FOUNDOPENSSL="yes" 507 FOUNDOPENSSL="yes"