summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEthan Galstad <egalstad@users.sourceforge.net>2002-04-18 04:38:46 (GMT)
committerEthan Galstad <egalstad@users.sourceforge.net>2002-04-18 04:38:46 (GMT)
commit05f12af006afa4b642059bbd3b4f4c3bd736719f (patch)
tree25f1e211a5e1336eb9c65b9b707abfc8a1be4659 /configure.in
parentd71f56c42e6fe08a81eef2667a868bddbf2b751e (diff)
downloadmonitoring-plugins-05f12af006afa4b642059bbd3b4f4c3bd736719f.tar.gz
configure script patch for ping syntax
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@15 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index b2df783..e7af901 100644
--- a/configure.in
+++ b/configure.in
@@ -554,38 +554,38 @@ then
554 then 554 then
555 AC_DEFINE_UNQUOTED(PING_PACKETS_FIRST,"$PING_COMMAND") 555 AC_DEFINE_UNQUOTED(PING_PACKETS_FIRST,"$PING_COMMAND")
556 fi 556 fi
557elif [ping -n -U -c 1 127.0.0.1 2>/dev/null | egrep -i "^round-trip" >/dev/null] 557elif [ping -n -U -c 1 127.0.0.1 2>/dev/null | egrep -i "^round-trip|^rtt" >/dev/null]
558then 558then
559 PING_COMMAND="$PATH_TO_PING -n -U -c %d %s" 559 PING_COMMAND="$PATH_TO_PING -n -U -c %d %s"
560 AC_DEFINE_UNQUOTED(PING_PACKETS_FIRST,"$PING_COMMAND") 560 AC_DEFINE_UNQUOTED(PING_PACKETS_FIRST,"$PING_COMMAND")
561 echo " ping syntax... $PATH_TO_PING -n -U -c <count> <host>" 561 echo " ping syntax... $PATH_TO_PING -n -U -c <count> <host>"
562elif [ping -n -c 1 127.0.0.1 2>/dev/null | egrep -i "^round-trip" >/dev/null] 562elif [ping -n -c 1 127.0.0.1 2>/dev/null | egrep -i "^round-trip|^rtt" >/dev/null]
563then 563then
564 PING_COMMAND="$PATH_TO_PING -n -c %d %s" 564 PING_COMMAND="$PATH_TO_PING -n -c %d %s"
565 AC_DEFINE_UNQUOTED(PING_PACKETS_FIRST,"$PING_COMMAND") 565 AC_DEFINE_UNQUOTED(PING_PACKETS_FIRST,"$PING_COMMAND")
566 echo " ping syntax... $PATH_TO_PING -n -c <count> <host>" 566 echo " ping syntax... $PATH_TO_PING -n -c <count> <host>"
567elif [ping -n 127.0.0.1 -c 1 2>/dev/null | egrep -i "^round-trip" >/dev/null] 567elif [ping -n 127.0.0.1 -c 1 2>/dev/null | egrep -i "^round-trip|^rtt" >/dev/null]
568then 568then
569 PING_COMMAND="$PATH_TO_PING -n %s -c %d" 569 PING_COMMAND="$PATH_TO_PING -n %s -c %d"
570 echo " ping syntax... $PATH_TO_PING -n <host> -c <count>" 570 echo " ping syntax... $PATH_TO_PING -n <host> -c <count>"
571elif [ping 127.0.0.1 -n 1 2>/dev/null | egrep -i "^round-trip" >/dev/null] 571elif [ping 127.0.0.1 -n 1 2>/dev/null | egrep -i "^round-trip|^rtt" >/dev/null]
572then 572then
573 PING_COMMAND="$PATH_TO_PING %s -n %d" 573 PING_COMMAND="$PATH_TO_PING %s -n %d"
574 echo " ping syntax... $PATH_TO_PING <host> -n <count>" 574 echo " ping syntax... $PATH_TO_PING <host> -n <count>"
575elif [ping -n -s 127.0.0.1 56 1 2>/dev/null | egrep -i "^round-trip" >/dev/null] 575elif [ping -n -s 127.0.0.1 56 1 2>/dev/null | egrep -i "^round-trip|^rtt" >/dev/null]
576then 576then
577 PING_COMMAND="$PATH_TO_PING -n -s %s 56 %d" 577 PING_COMMAND="$PATH_TO_PING -n -s %s 56 %d"
578 echo " ping syntax... $PATH_TO_PING -n -s <host> 56 <count>" 578 echo " ping syntax... $PATH_TO_PING -n -s <host> 56 <count>"
579elif [ping -n -h 127.0.0.1 -s 56 -c 1 2>/dev/null | egrep -i "^round-trip" >/dev/null] 579elif [ping -n -h 127.0.0.1 -s 56 -c 1 2>/dev/null | egrep -i "^round-trip|^rtt" >/dev/null]
580then 580then
581 PING_COMMAND="$PATH_TO_PING -n -h %s -s 56 -c %d" 581 PING_COMMAND="$PATH_TO_PING -n -h %s -s 56 -c %d"
582 echo " ping syntax... $PATH_TO_PING -n -h <host> -s 56 -c <count>" 582 echo " ping syntax... $PATH_TO_PING -n -h <host> -s 56 -c <count>"
583elif [ping -n -s 56 -c 1 127.0.0.1 2>/dev/null | egrep -i "^round-trip" >/dev/null] 583elif [ping -n -s 56 -c 1 127.0.0.1 2>/dev/null | egrep -i "^round-trip|^rtt" >/dev/null]
584then 584then
585 PING_COMMAND="$PATH_TO_PING -n -s 56 -c %d %s" 585 PING_COMMAND="$PATH_TO_PING -n -s 56 -c %d %s"
586 AC_DEFINE_UNQUOTED(PING_PACKETS_FIRST,"$PING_COMMAND") 586 AC_DEFINE_UNQUOTED(PING_PACKETS_FIRST,"$PING_COMMAND")
587 echo " ping syntax... $PATH_TO_PING -n -s 56 -c <count> <host>" 587 echo " ping syntax... $PATH_TO_PING -n -s 56 -c <count> <host>"
588elif [ping -n -c 1 127.0.0.1 2>/dev/null | egrep -i "^round-trip" >/dev/null] 588elif [ping -n -c 1 127.0.0.1 2>/dev/null | egrep -i "^round-trip|^rtt" >/dev/null]
589then 589then
590 PING_COMMAND="$PATH_TO_PING -n -c %d %s" 590 PING_COMMAND="$PATH_TO_PING -n -c %d %s"
591 AC_DEFINE_UNQUOTED(PING_PACKETS_FIRST,"$PING_COMMAND") 591 AC_DEFINE_UNQUOTED(PING_PACKETS_FIRST,"$PING_COMMAND")