summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Guyot-Sionnest <dermoth@users.sourceforge.net>2008-04-02 09:11:44 (GMT)
committerThomas Guyot-Sionnest <dermoth@users.sourceforge.net>2008-04-02 09:11:44 (GMT)
commit0d13deb0e44afb80ec0a35e827548d891d48f6b6 (patch)
tree7723807c1c17109104f6ebf3fea141e87a50ba46 /configure.in
parent63897a417917907099b72f4e679890355a7a78a0 (diff)
downloadmonitoring-plugins-0d13deb0e44afb80ec0a35e827548d891d48f6b6.tar.gz
- Add --enable-extra-opts configure option for compiling extra-opts support
- Auto-update po/pot files git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1973 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d0bd0ef..418b597 100644
--- a/configure.in
+++ b/configure.in
@@ -160,6 +160,19 @@ AC_CHECK_LIB(tap, plan_tests,
160 AC_SUBST(EXTRA_TEST) 160 AC_SUBST(EXTRA_TEST)
161 ) 161 )
162 162
163dnl INI Parsing
164AC_ARG_ENABLE(extra-opts,
165 AC_HELP_STRING([--enable-extra-opts],
166 [Enables parsing of plugins ini config files for extra options (default: no)]),
167 [enable_extra_opts=$enableval],
168 [enable_extra_opts=no])
169AM_CONDITIONAL([USE_PARSE_INI],[test "$enable_extra_opts" = "yes"])
170if test "$enable_extra_opts" = "yes" ; then
171 EXTRA_TEST="$EXTRA_TEST test_ini test_opts"
172 AC_SUBST(EXTRA_TEST)
173 AC_DEFINE(NP_EXTRA_OPTS,[1],[Enable INI file parsing.])
174fi
175
163dnl Check for PostgreSQL libraries 176dnl Check for PostgreSQL libraries
164_SAVEDLIBS="$LIBS" 177_SAVEDLIBS="$LIBS"
165_SAVEDCPPFLAGS="$CPPFLAGS" 178_SAVEDCPPFLAGS="$CPPFLAGS"
@@ -1621,6 +1634,7 @@ ACX_FEATURE([with],[ipv6])
1621ACX_FEATURE([with],[mysql]) 1634ACX_FEATURE([with],[mysql])
1622ACX_FEATURE([with],[openssl]) 1635ACX_FEATURE([with],[openssl])
1623ACX_FEATURE([with],[gnutls]) 1636ACX_FEATURE([with],[gnutls])
1637ACX_FEATURE([enable],[extra-opts])
1624ACX_FEATURE([with],[perl]) 1638ACX_FEATURE([with],[perl])
1625ACX_FEATURE([enable],[perl-modules]) 1639ACX_FEATURE([enable],[perl-modules])
1626ACX_FEATURE([with],[cgiurl]) 1640ACX_FEATURE([with],[cgiurl])