summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Guyot-Sionnest <dermoth@aei.ca>2008-11-28 08:22:39 (GMT)
committerThomas Guyot-Sionnest <dermoth@aei.ca>2008-11-28 08:22:39 (GMT)
commit538b97cea63d68efbd9c9c67d9c41278cfd1ebad (patch)
tree84e707f97fb82f1920fb7568241e8b5d8f71c0af /configure.in
parentd40abb2504b99e1318840ad1a5d9f4a340c465b5 (diff)
downloadmonitoring-plugins-538b97cea63d68efbd9c9c67d9c41278cfd1ebad.tar.gz
Revert inclusion of libtap into nagiosplugins
(except for the NEWS file) This reverts the following commits (latest first): f3e0909, 9f16b54, be8df51, f31cd40, 5270c7d, a25083f, f1bfe40, c503d85 and 6c476db
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 5 insertions, 21 deletions
diff --git a/configure.in b/configure.in
index 8cae534..39cd6b7 100644
--- a/configure.in
+++ b/configure.in
@@ -156,25 +156,11 @@ AC_CHECK_HEADERS(math.h)
156AC_CHECK_LIB(m,floor,MATHLIBS="-lm") 156AC_CHECK_LIB(m,floor,MATHLIBS="-lm")
157AC_SUBST(MATHLIBS) 157AC_SUBST(MATHLIBS)
158 158
159dnl Add libtap for tests 159dnl Check for libtap, to run perl-like tests
160AC_ARG_ENABLE(libtap, 160AC_CHECK_LIB(tap, plan_tests,
161 AC_HELP_STRING([--enable-libtap],
162 [Enables configuring of libtap in external/tap/. Run "make tap" to compile (default: no)]),
163 [enable_libtap=$enableval],
164 [enable_libtap=no])
165dnl Have to define TAP_DIR so that Makefile can pull it as an extra dist
166TAP_DIR=external/tap-1.01
167AC_SUBST(TAP_DIR)
168if test "$enable_libtap" = yes; then
169 dnl Have to have AC_CONFIG_SUBDIRS as a literal
170 AC_CONFIG_SUBDIRS([external/tap-1.01])
171 dnl This is required so that TAP stuff is compiled before the libs and tests
172 dnl A make install will also install the tap library, but as this is a development tool, this should be okay
173 INCLUDE_TAP_DIR=$TAP_DIR
174 AC_SUBST(INCLUDE_TAP_DIR)
175 EXTRA_TEST="test_utils test_disk test_tcp test_cmd test_base64" 161 EXTRA_TEST="test_utils test_disk test_tcp test_cmd test_base64"
176 AC_SUBST(EXTRA_TEST) 162 AC_SUBST(EXTRA_TEST)
177fi 163 )
178 164
179dnl INI Parsing 165dnl INI Parsing
180AC_ARG_ENABLE(extra-opts, 166AC_ARG_ENABLE(extra-opts,
@@ -184,11 +170,9 @@ AC_ARG_ENABLE(extra-opts,
184 [enable_extra_opts=no]) 170 [enable_extra_opts=no])
185AM_CONDITIONAL([USE_PARSE_INI],[test "$enable_extra_opts" = "yes"]) 171AM_CONDITIONAL([USE_PARSE_INI],[test "$enable_extra_opts" = "yes"])
186if test "$enable_extra_opts" = "yes" ; then 172if test "$enable_extra_opts" = "yes" ; then
173 EXTRA_TEST="$EXTRA_TEST test_ini test_opts"
174 AC_SUBST(EXTRA_TEST)
187 AC_DEFINE(NP_EXTRA_OPTS,[1],[Enable INI file parsing.]) 175 AC_DEFINE(NP_EXTRA_OPTS,[1],[Enable INI file parsing.])
188 if test "$enable_libtap" = yes; then
189 EXTRA_TEST="$EXTRA_TEST test_ini test_opts"
190 AC_SUBST(EXTRA_TEST)
191 fi
192fi 176fi
193 177
194dnl Check for PostgreSQL libraries 178dnl Check for PostgreSQL libraries