summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2004-12-20 21:26:41 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2004-12-20 21:26:41 (GMT)
commit6240b64efd8a4148e90b029cf86b20a69439ce34 (patch)
tree13f43951e959ad14d318f317fb0254c551017b42 /configure.in
parent7bd302bd788d07391ca1c9d284bf443438fd4cfd (diff)
downloadmonitoring-plugins-6240b64efd8a4148e90b029cf86b20a69439ce34.tar.gz
Fix compile errors when looking for openssl
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1040 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 11 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 21d28de..8c19635 100644
--- a/configure.in
+++ b/configure.in
@@ -293,12 +293,12 @@ else
293 dnl Check usual areas for openssl 293 dnl Check usual areas for openssl
294 if test "$PKGTEST" = "yes"; then 294 if test "$PKGTEST" = "yes"; then
295 AC_PATH_PROG(OPENSSL,openssl) 295 AC_PATH_PROG(OPENSSL,openssl)
296 # Don't think 2 tests below are necessary because /usr is always included 296 dnl The /usr checks need to be done so that the right area is include'd
297 # if test "$OPENSSL" = "/usr/bin/openssl"; then 297 if test "$OPENSSL" = "/usr/bin/openssl"; then
298 # OPENSSL=/usr 298 OPENSSL=/usr
299 #elif test "$OPENSSL" = "/usr/sbin/openssl"; then 299 elif test "$OPENSSL" = "/usr/sbin/openssl"; then
300 # OPENSSL=/usr 300 OPENSSL=/usr
301 if test "$OPENSSL" = "/opt/bin/openssl"; then 301 elif test "$OPENSSL" = "/opt/bin/openssl"; then
302 OPENSSL=/opt 302 OPENSSL=/opt
303 elif test "$OPENSSL" = "/opt/openssl/bin/openssl"; then 303 elif test "$OPENSSL" = "/opt/openssl/bin/openssl"; then
304 OPENSSL=/opt/openssl 304 OPENSSL=/opt/openssl
@@ -386,7 +386,11 @@ else
386 fi 386 fi
387 387
388 if test "$OPENSSL_ENABLED" != "1"; then 388 if test "$OPENSSL_ENABLED" != "1"; then
389 AC_MSG_WARN([OpenSSL libs and/or directories were not found where specified!]) 389 if test "$PKGTEST" ="yes"; then
390 AC_MSG_WARN([OpenSSL libs could not be found])
391 else
392 AC_MSG_WARN([OpenSSL libs and/or directories were not found where specified!])
393 fi
390 with_openssl="no" 394 with_openssl="no"
391 else 395 else
392 check_tcp_ssl="check_simap check_spop check_jabber check_nntps" 396 check_tcp_ssl="check_simap check_spop check_jabber check_nntps"