summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMonitoring Plugins Development Team <devel@monitoring-plugins.org>2014-01-18 08:40:24 (GMT)
committerThomas Guyot-Sionnest <dermoth@aei.ca>2014-01-19 19:18:47 (GMT)
commit63734f52ab1b4b2c17545b26fc41016d6bbd80bd (patch)
treedcd7aa3fd9a2a6a69a47d3a7e6a18d034426087a /configure.in
parent9db763963f3993f923619a2147e4313b09f12134 (diff)
downloadmonitoring-plugins-63734f52ab1b4b2c17545b26fc41016d6bbd80bd.tar.gz
Project rename initial commit.
This is an initial take at renaming the project to Monitoring Plugins. It's not expected to be fully complete, and it is expected to break things (The perl module for instance). More testing will be required before this goes mainline.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index a20ca87..f0c696f 100644
--- a/configure.in
+++ b/configure.in
@@ -1,9 +1,9 @@
1dnl Process this file with autoconf to produce a configure script. 1dnl Process this file with autoconf to produce a configure script.
2AC_PREREQ(2.59) 2AC_PREREQ(2.59)
3AC_INIT(nagios-plugins,1.5) 3AC_INIT(monitoring-plugins,1.5)
4AC_CONFIG_SRCDIR(NPTest.pm) 4AC_CONFIG_SRCDIR(NPTest.pm)
5AC_CONFIG_FILES([gl/Makefile 5AC_CONFIG_FILES([gl/Makefile
6 nagios-plugins.spec]) 6 monitoring-plugins.spec])
7AC_CONFIG_AUX_DIR(build-aux) 7AC_CONFIG_AUX_DIR(build-aux)
8AM_INIT_AUTOMAKE([1.8.3]) 8AM_INIT_AUTOMAKE([1.8.3])
9AC_CONFIG_HEADERS([config.h]) 9AC_CONFIG_HEADERS([config.h])
@@ -58,10 +58,10 @@ AC_SUBST(PLUGIN_TEST)dnl
58SCRIPT_TEST=`echo $srcdir/plugins-scripts/t/*.t|sed -e 's,\.*/plugins-scripts/,,g'` 58SCRIPT_TEST=`echo $srcdir/plugins-scripts/t/*.t|sed -e 's,\.*/plugins-scripts/,,g'`
59AC_SUBST(SCRIPT_TEST)dnl 59AC_SUBST(SCRIPT_TEST)dnl
60 60
61WARRANTY="The nagios plugins come with ABSOLUTELY NO WARRANTY. You may redistribute\ncopies of the plugins under the terms of the GNU General Public License.\nFor more information about these matters, see the file named COPYING.\n" 61WARRANTY="The monitoring plugins come with ABSOLUTELY NO WARRANTY. You may redistribute\ncopies of the plugins under the terms of the GNU General Public License.\nFor more information about these matters, see the file named COPYING.\n"
62AC_SUBST(WARRANTY) 62AC_SUBST(WARRANTY)
63 63
64SUPPORT="Send email to nagios-users@lists.sourceforge.net if you have questions\nregarding use of this software. To submit patches or suggest improvements,\nsend email to nagiosplug-devel@lists.sourceforge.net.\nPlease include version information with all correspondence (when possible,\nuse output from the --version option of the plugin itself).\n" 64SUPPORT="Send email to devel@monitoring-plugins.org if you have questions\nregarding use of this software. To submit patches or suggest improvements,\nsend email to devel@monitoring-plugins.org.\nPlease include version information with all correspondence (when possible,\nuse output from the --version option of the plugin itself).\n"
65AC_SUBST(SUPPORT) 65AC_SUBST(SUPPORT)
66 66
67dnl CGIURL has changed for Nagios with 1.0 beta 67dnl CGIURL has changed for Nagios with 1.0 beta
@@ -648,7 +648,7 @@ elif test "$ac_cv_uname_s" = "SunOS"; then
648 ac_cv_ps_format="%s %d %d %d %d %d %f %s %n" 648 ac_cv_ps_format="%s %d %d %d %d %d %f %s %n"
649 ac_cv_ps_varlist="[procstat,&procuid,&procpid,&procppid,&procvsz,&procrss,&procpcpu,procprog,&pos]" 649 ac_cv_ps_varlist="[procstat,&procuid,&procpid,&procppid,&procvsz,&procrss,&procpcpu,procprog,&pos]"
650 ac_cv_ps_cols=9 650 ac_cv_ps_cols=9
651 AC_MSG_RESULT([using nagios-plugins internal ps command (pst3) for solaris]) 651 AC_MSG_RESULT([using monitoring-plugins internal ps command (pst3) for solaris])
652 if test `isainfo -b` = 64 ; then 652 if test `isainfo -b` = 64 ; then
653 pst3_use_64bit=1 653 pst3_use_64bit=1
654 AC_MSG_NOTICE([using 64bit pst3]) 654 AC_MSG_NOTICE([using 64bit pst3])
@@ -1731,7 +1731,7 @@ AC_ARG_ENABLE(redhat-pthread-workaround,
1731 [ac_cv_enable_redhat_pthread_workaround=test]) 1731 [ac_cv_enable_redhat_pthread_workaround=test])
1732if test "$ac_cv_enable_redhat_pthread_workaround" = "test" ; then 1732if test "$ac_cv_enable_redhat_pthread_workaround" = "test" ; then
1733 if echo $ac_cv_uname_r | egrep "\.EL(smp)?$" >/dev/null 2>&1 ; then 1733 if echo $ac_cv_uname_r | egrep "\.EL(smp)?$" >/dev/null 2>&1 ; then
1734 AC_MSG_NOTICE([See http://nagiosplugins.org/faq/compile/configure_appears_to_hang if this next part takes a long time]) 1734 AC_MSG_NOTICE([See https://www.monitoring-plugins.org/doc/faq/configure-hangs.html if this next part takes a long time])
1735 AC_MSG_CHECKING(for redhat spopen problem) 1735 AC_MSG_CHECKING(for redhat spopen problem)
1736 ( cd config_test && make && make test ) > /dev/null 2>&1 1736 ( cd config_test && make && make test ) > /dev/null 2>&1
1737 if test $? -eq 0 ; then 1737 if test $? -eq 0 ; then
@@ -1748,7 +1748,7 @@ fi
1748dnl Perl modules 1748dnl Perl modules
1749AC_ARG_ENABLE(perl-modules, 1749AC_ARG_ENABLE(perl-modules,
1750 AC_HELP_STRING([--enable-perl-modules], 1750 AC_HELP_STRING([--enable-perl-modules],
1751 [Enables installation of Nagios::Plugin and its dependencies (default: no)]), 1751 [Enables installation of Monitoring::Plugin and its dependencies (default: no)]),
1752 [enable_perl_modules=$enableval], 1752 [enable_perl_modules=$enableval],
1753 [enable_perl_modules=no]) 1753 [enable_perl_modules=no])
1754if test "$enable_perl_modules" = "yes" ; then 1754if test "$enable_perl_modules" = "yes" ; then