summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorVille Mattila <vmattila@csc.fi>2012-12-28 08:26:13 (GMT)
committerVille Mattila <vmattila@csc.fi>2012-12-28 08:26:13 (GMT)
commit6515124a47364088f152151490c7a0cefb09b6fb (patch)
tree7fc3f934c946a705cf3e0ed3108af2b42f11e245 /configure.in
parent1845c4cdf98fe9cf4bc95b6e11ae94cec1dcd4cc (diff)
downloadmonitoring-plugins-6515124a47364088f152151490c7a0cefb09b6fb.tar.gz
check_fping: IPv6 supportrefs/pull/30/head
Add command line options -4 and -6 (--use-ipv4 and --use-ipv6) to check_fping. IPv4 is used by default, maintaining backwards compatibility with older check_fping versions. IPv6 support requires the fping6 program. The implementation is really just an imitation of check_ping IPv6 support: Plugin command line option -4/-6 designates whether to run fping/fping6. Please note that especially the changes to configure.in might be all wrong - I don't know what's the proper autoconf way, patching configure.in just seemed to work for me.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1d4ed00..93b355e 100644
--- a/configure.in
+++ b/configure.in
@@ -1378,6 +1378,17 @@ else
1378 AC_MSG_WARN([Get fping from http://www.fping.com in order to make check_fping plugin]) 1378 AC_MSG_WARN([Get fping from http://www.fping.com in order to make check_fping plugin])
1379fi 1379fi
1380 1380
1381AC_PATH_PROG(PATH_TO_FPING6,fping6)
1382AC_ARG_WITH(fping6_command,
1383 ACX_HELP_STRING([--with-fping6-command=PATH],
1384 [Path to fping6 command]), PATH_TO_FPING6=$withval)
1385if test -n "$PATH_TO_FPING6"
1386then
1387 AC_DEFINE_UNQUOTED(PATH_TO_FPING6,"$PATH_TO_FPING6",[path to fping6])
1388else
1389 AC_MSG_WARN([Get fping6 from http://www.fping.com in order to make check_fping plugin])
1390fi
1391
1381AC_PATH_PROG(PATH_TO_SSH,ssh) 1392AC_PATH_PROG(PATH_TO_SSH,ssh)
1382AC_ARG_WITH(ssh_command, 1393AC_ARG_WITH(ssh_command,
1383 ACX_HELP_STRING([--with-ssh-command=PATH], 1394 ACX_HELP_STRING([--with-ssh-command=PATH],