summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2008-06-26 22:00:08 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2008-06-26 22:00:08 (GMT)
commit6c476db6dcc7aa70a687d09c10e6ad515c290c23 (patch)
tree01262e224740a0b01fe018eb167b3c46de3a6ea7 /configure.in
parent2968a166e2524c5c1c557a12ae8dd6eaf698d7ea (diff)
downloadmonitoring-plugins-6c476db6dcc7aa70a687d09c10e6ad515c290c23.tar.gz
Adding libtap into distribution to help run C based tests
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@2013 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 15 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 612d686..afde837 100644
--- a/configure.in
+++ b/configure.in
@@ -154,12 +154,6 @@ AC_CHECK_HEADERS(math.h)
154AC_CHECK_LIB(m,floor,MATHLIBS="-lm") 154AC_CHECK_LIB(m,floor,MATHLIBS="-lm")
155AC_SUBST(MATHLIBS) 155AC_SUBST(MATHLIBS)
156 156
157dnl Check for libtap, to run perl-like tests
158AC_CHECK_LIB(tap, plan_tests,
159 EXTRA_TEST="test_utils test_disk test_tcp test_cmd test_base64"
160 AC_SUBST(EXTRA_TEST)
161 )
162
163dnl INI Parsing 157dnl INI Parsing
164AC_ARG_ENABLE(extra-opts, 158AC_ARG_ENABLE(extra-opts,
165 AC_HELP_STRING([--enable-extra-opts], 159 AC_HELP_STRING([--enable-extra-opts],
@@ -1595,6 +1589,21 @@ if test "$ac_cv_uname_s" = 'SunOS' -a \( "x$ac_cv_prog_ac_ct_AR" = "x" -o "$ac_c
1595 AC_MSG_ERROR(No ar found for Solaris - is /usr/ccs/bin in PATH?) 1589 AC_MSG_ERROR(No ar found for Solaris - is /usr/ccs/bin in PATH?)
1596fi 1590fi
1597 1591
1592AC_ARG_ENABLE(libtap,
1593 AC_HELP_STRING([--enable-libtap],
1594 [Enables configuring of libtap in external/tap/. Run "make tap" to compile (default: no)]),
1595 [enable_libtap=$enableval],
1596 [enable_libtap=no])
1597dnl Have to define TAP_DIR so that Makefile can pull it as an extra dist
1598TAP_DIR=external/tap-1.01
1599AC_SUBST(TAP_DIR)
1600if test "$enable_libtap" = yes; then
1601 dnl Have to have AC_CONFIG_SUBDIRS as a literal
1602 AC_CONFIG_SUBDIRS([external/tap-1.01])
1603 EXTRA_TEST="test_utils test_disk test_tcp test_cmd test_base64"
1604 AC_SUBST(EXTRA_TEST)
1605fi
1606
1598AC_OUTPUT( 1607AC_OUTPUT(
1599 Makefile 1608 Makefile
1600 lib/Makefile 1609 lib/Makefile