summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2003-06-27 14:43:01 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2003-06-27 14:43:01 (GMT)
commit912e0863dd29cab4b2c637910efb1415347e9e22 (patch)
treed2ca5a24b3054daa118b5a3b1e6308a7af02f8bc /configure.in
parenta8b5f3eda1594a4ee77f1062fb57a8de32aef56b (diff)
downloadmonitoring-plugins-912e0863dd29cab4b2c637910efb1415347e9e22.tar.gz
Support for swap -s for solaris. Also changes size of swap to MBs through
a conversion amount in configure. Possible breakage on other OSes git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@561 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 2c90ebf..81b019b 100644
--- a/configure.in
+++ b/configure.in
@@ -1305,16 +1305,19 @@ then
1305 >/dev/null] 1305 >/dev/null]
1306 then 1306 then
1307 ac_cv_swap_format=[" %*d %*s %*d,%*d %*d %*d %d %d"] 1307 ac_cv_swap_format=[" %*d %*s %*d,%*d %*d %*d %d %d"]
1308 ac_cv_swap_conv=2048
1308 AC_MSG_RESULT([using IRIX format swap]) 1309 AC_MSG_RESULT([using IRIX format swap])
1309 1310
1310 elif [$PATH_TO_SWAP -l 2>/dev/null | egrep -i "^swapfile +dev +swaplo +blocks +free" >/dev/null] 1311 elif [$PATH_TO_SWAP -l 2>/dev/null | egrep -i "^swapfile +dev +swaplo +blocks +free" >/dev/null]
1311 then 1312 then
1312 ac_cv_swap_format=["%*s %*[0-9,-] %*d %d %d"] 1313 ac_cv_swap_format=["%*s %*[0-9,-] %*d %d %d"]
1314 ac_cv_swap_conv=2048
1313 AC_MSG_RESULT([using Solaris format swap]) 1315 AC_MSG_RESULT([using Solaris format swap])
1314 1316
1315 elif [$PATH_TO_SWAP -l 2>/dev/null | egrep -i "^path +dev +swaplo +blocks +free" >/dev/null] 1317 elif [$PATH_TO_SWAP -l 2>/dev/null | egrep -i "^path +dev +swaplo +blocks +free" >/dev/null]
1316 then 1318 then
1317 ac_cv_swap_format=["%*s %*[0-9,-] %*d %d %d"] 1319 ac_cv_swap_format=["%*s %*[0-9,-] %*d %d %d"]
1320 ac_cv_swap_conv=2048
1318 AC_MSG_RESULT([using Unixware format swap]) 1321 AC_MSG_RESULT([using Unixware format swap])
1319 1322
1320 fi 1323 fi
@@ -1328,6 +1331,7 @@ then
1328 if [$PATH_TO_SWAPINFO -k 2>/dev/null | egrep -i "^Device +1K-blocks +Used +Avail" >/dev/null] 1331 if [$PATH_TO_SWAPINFO -k 2>/dev/null | egrep -i "^Device +1K-blocks +Used +Avail" >/dev/null]
1329 then 1332 then
1330 ac_cv_swap_format=["%*s %d %*d %d"] 1333 ac_cv_swap_format=["%*s %d %*d %d"]
1334 ac_cv_swap_conv=1024
1331 AC_MSG_RESULT([using FreeBSD format swapinfo]) 1335 AC_MSG_RESULT([using FreeBSD format swapinfo])
1332 fi 1336 fi
1333 EXTRAS="$EXTRAS check_swap" 1337 EXTRAS="$EXTRAS check_swap"
@@ -1337,19 +1341,22 @@ then
1337 ac_cv_have_swap=yes 1341 ac_cv_have_swap=yes
1338 ac_cv_swap_command="$PATH_TO_SWAPINFO -dfM", 1342 ac_cv_swap_command="$PATH_TO_SWAPINFO -dfM",
1339 ac_cv_swap_format=["%*s %d %*d %d"] 1343 ac_cv_swap_format=["%*s %d %*d %d"]
1344 ac_cv_swap_conv=1024
1340 AC_MSG_RESULT([using HP-UX format swapinfo]) 1345 AC_MSG_RESULT([using HP-UX format swapinfo])
1341fi 1346fi
1342 1347
1343if test x$ac_cv_have_swap != x 1348if test "x$ac_cv_have_swap" != "x"
1344then 1349then
1345 AC_DEFINE(HAVE_SWAP,1,[Define if swap/swapinfo command is found]) 1350 AC_DEFINE(HAVE_SWAP,1,[Define if swap/swapinfo command is found])
1346fi 1351fi
1347AC_DEFINE_UNQUOTED(SWAP_FORMAT,"$ac_cv_swap_format",
1348 [Format string for parsing swap output])
1349if test "x$ac_cv_swap_command" != "x" 1352if test "x$ac_cv_swap_command" != "x"
1350then 1353then
1351 AC_DEFINE_UNQUOTED(SWAP_COMMAND,"$ac_cv_swap_command", 1354 AC_DEFINE_UNQUOTED(SWAP_COMMAND,"$ac_cv_swap_command",
1352 [Path to swap/swapinfo binary, with any args]) 1355 [Path to swap/swapinfo binary, with any args])
1356 AC_DEFINE_UNQUOTED(SWAP_FORMAT,"$ac_cv_swap_format",
1357 [Format string for parsing swap output])
1358 AC_DEFINE_UNQUOTED(SWAP_CONVERSION,$ac_cv_swap_conv,
1359 [Conversion factor to MB])
1353fi 1360fi
1354 1361
1355AC_PATH_PROG(PATH_TO_DIG,dig) 1362AC_PATH_PROG(PATH_TO_DIG,dig)