summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2004-11-20 07:04:13 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2004-11-20 07:04:13 (GMT)
commita8af4ed87437b2565eb2d098d7b6c30b5a74dd87 (patch)
treeafaebe7c4c0baf5a77bdbb00b7ee57c972a8e910 /configure.in
parent870988ff0cde7aff6794e9a6a27904562cad9291 (diff)
downloadmonitoring-plugins-a8af4ed87437b2565eb2d098d7b6c30b5a74dd87.tar.gz
Fixed va_copy problem on AIX by copying samba's configure.in
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@914 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 15 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index be3a212..8d8e1e3 100644
--- a/configure.in
+++ b/configure.in
@@ -33,7 +33,7 @@ jm_PREREQ_ERROR
33AC_FUNC_ERROR_AT_LINE 33AC_FUNC_ERROR_AT_LINE
34 34
35AC_CONFIG_LIBOBJ_DIR(lib) 35AC_CONFIG_LIBOBJ_DIR(lib)
36AC_FUNC_GETLOADAVG($topdir/lib) 36AC_FUNC_GETLOADAVG([lib])
37 37
38ifdef([AC_FUNC_STRTOD],[AC_FUNC_STRTOD],[AM_FUNC_STRTOD]) 38ifdef([AC_FUNC_STRTOD],[AC_FUNC_STRTOD],[AM_FUNC_STRTOD])
39dnl AM_WITH_REGEX 39dnl AM_WITH_REGEX
@@ -557,12 +557,22 @@ if test x"$ac_cv_compiler_supports_ll" = x"yes"; then
557 AC_DEFINE(COMPILER_SUPPORTS_LL,1,[Define if compiler support long long]) 557 AC_DEFINE(COMPILER_SUPPORTS_LL,1,[Define if compiler support long long])
558fi 558fi
559 559
560AC_CACHE_CHECK([for __va_copy],ac_cv_HAVE_VA_COPY,[ 560AC_CACHE_CHECK([for va_copy],ac_cv_HAVE_VA_COPY,[
561AC_TRY_LINK([#include <stdarg.h> 561AC_TRY_LINK([#include <stdarg.h>
562va_list ap1,ap2;], [__va_copy(ap1,ap2);], 562va_list ap1,ap2;], [va_copy(ap1,ap2);],
563ac_cv_HAVE_VA_COPY=yes,ac_cv_HAVE_VA_COPY=no)]) 563ac_cv_HAVE_VA_COPY=yes,
564ac_cv_HAVE_VA_COPY=no)])
564if test x"$ac_cv_HAVE_VA_COPY" = x"yes"; then 565if test x"$ac_cv_HAVE_VA_COPY" = x"yes"; then
565 AC_DEFINE(HAVE_VA_COPY,1,[Define if system has va_copy]) 566 AC_DEFINE(HAVE_VA_COPY,1,[Whether va_copy() is available])
567else
568 AC_CACHE_CHECK([for __va_copy],ac_cv_HAVE___VA_COPY,[
569 AC_TRY_LINK([#include <stdarg.h>
570 va_list ap1,ap2;], [__va_copy(ap1,ap2);],
571 ac_cv_HAVE___VA_COPY=yes,
572 ac_cv_HAVE___VA_COPY=no)])
573 if test x"$ac_cv_HAVE___VA_COPY" = x"yes"; then
574 AC_DEFINE(HAVE___VA_COPY,1,[Whether __va_copy() is available])
575 fi
566fi 576fi
567 577
568AC_CHECK_FUNCS(vsnprintf snprintf asprintf vasprintf) 578AC_CHECK_FUNCS(vsnprintf snprintf asprintf vasprintf)