summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorM. Sean Finney <seanius@users.sourceforge.net>2005-06-28 00:26:53 (GMT)
committerM. Sean Finney <seanius@users.sourceforge.net>2005-06-28 00:26:53 (GMT)
commitd4c0948266f261525e12c58d58e0fc68987a9818 (patch)
treee7d8e6afe6c425a1e51446ace47b0fc4e99dcfd0 /configure.in
parentf573447d1f6dbf25b58bbfea81226a2ae3736555 (diff)
downloadmonitoring-plugins-d4c0948266f261525e12c58d58e0fc68987a9818.tar.gz
scanf parsing fix for check_swap from tracker id 1123292. now use floor(3)
to round down floating point numbers. requires -lm on many systems, so support for testing for this was added to the configure.in and automake template git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1194 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index df516c5..b209d19 100644
--- a/configure.in
+++ b/configure.in
@@ -137,6 +137,11 @@ AC_CHECK_LIB(socket,socket,SOCKETLIBS="$SOCKETLIBS -lsocket")
137AC_CHECK_LIB(resolv,main,SOCKETLIBS="$SOCKETLIBS -lresolv") 137AC_CHECK_LIB(resolv,main,SOCKETLIBS="$SOCKETLIBS -lresolv")
138AC_SUBST(SOCKETLIBS) 138AC_SUBST(SOCKETLIBS)
139 139
140dnl
141dnl check for math-related functions needing -lm
142AC_CHECK_LIB(m,floor,MATHLIBS="-lm")
143AC_SUBST(MATHLIBS)
144
140dnl Check for PostgreSQL libraries 145dnl Check for PostgreSQL libraries
141_SAVEDLIBS="$LIBS" 146_SAVEDLIBS="$LIBS"
142_SAVEDCPPFLAGS="$CPPFLAGS" 147_SAVEDCPPFLAGS="$CPPFLAGS"
@@ -567,7 +572,7 @@ AC_TRY_COMPILE([#include <sys/time.h>],
567 AC_DEFINE(NEED_GETTIMEOFDAY,1,[Define if gettimeofday is needed]))) 572 AC_DEFINE(NEED_GETTIMEOFDAY,1,[Define if gettimeofday is needed])))
568 573
569dnl Checks for library functions. 574dnl Checks for library functions.
570AC_CHECK_FUNCS(memmove select socket strdup strstr strtod strtol strtoul) 575AC_CHECK_FUNCS(memmove select socket strdup strstr strtod strtol strtoul, floor)
571 576
572AC_MSG_CHECKING(return type of socket size) 577AC_MSG_CHECKING(return type of socket size)
573AC_TRY_COMPILE([#include <stdlib.h> 578AC_TRY_COMPILE([#include <stdlib.h>