summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorM. Sean Finney <seanius@users.sourceforge.net>2006-05-01 21:52:42 (GMT)
committerM. Sean Finney <seanius@users.sourceforge.net>2006-05-01 21:52:42 (GMT)
commite667553b97c358f5d80608f62c291deffc0328d5 (patch)
tree4e74625613f8d13f51752d84f03b436b45164ff7 /configure.in
parent3b91dfbcb05dbfa9a1a20c6ba233c5d163e06821 (diff)
downloadmonitoring-plugins-e667553b97c358f5d80608f62c291deffc0328d5.tar.gz
- check_ntp:
- now roughly feature-complete. - various bugfixes, esp. offset calculation. - enhanced the asynchronous offset polling to set requests that haven't recieved a response in >= 1 second to stale and retransmit them, which results in much better performance on unreliable networks. - we only spend timeout/2 seconds polling offsets, and if we don't get everything by that point we work with what we have and set status to warning/critical depending on how much data we have. - set the same defaults as the perl script. - commit changes to configure.in to support automatic building of check_apt (if apt-get is installed and regex libraries available) and check_ntp (unconditionally), now defaulting to check_ntp.c instead of the perl script. if this is an issue we can back out the commit of course. an eye should be kept on check_ntp building and running correctly in different environments, esp. 64-bit and big-endian platforms, and those with more "esoteric" API's (do any of the platforms not have poll()?). - similar changes to Makefile.am's. - common.h: add statement to include sys/poll.h - runcmd.c: exit STATE_UNKNOWN if execve() fails. git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1386 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 17 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index c143905..6556ecd 100644
--- a/configure.in
+++ b/configure.in
@@ -529,8 +529,9 @@ dnl
529AC_HEADER_STDC 529AC_HEADER_STDC
530AC_HEADER_TIME 530AC_HEADER_TIME
531AC_HEADER_SYS_WAIT 531AC_HEADER_SYS_WAIT
532AC_CHECK_HEADERS(signal.h strings.h string.h syslog.h uio.h errno.h regex.h sys/types.h sys/time.h sys/socket.h sys/loadavg.h sys/un.h) 532AC_CHECK_HEADERS(signal.h strings.h string.h syslog.h uio.h errno.h sys/types.h sys/time.h sys/socket.h sys/loadavg.h sys/un.h sys/poll.h)
533AC_CHECK_HEADERS(features.h stdarg.h sys/unistd.h ctype.h stdlib.h) 533AC_CHECK_HEADERS(features.h stdarg.h sys/unistd.h ctype.h stdlib.h)
534AC_CHECK_HEADERS(regex.h,FOUNDREGEX=yes,FOUNDREGEX=no)
534 535
535dnl Checks for typedefs, structures, and compiler characteristics. 536dnl Checks for typedefs, structures, and compiler characteristics.
536AC_C_CONST 537AC_C_CONST
@@ -601,7 +602,7 @@ AC_TRY_COMPILE([#include <sys/time.h>],
601 602
602dnl Checks for library functions. 603dnl Checks for library functions.
603AC_CHECK_FUNCS(memmove select socket strdup strstr strtod strtol strtoul floor) 604AC_CHECK_FUNCS(memmove select socket strdup strstr strtod strtol strtoul floor)
604AC_CHECK_FUNCS(basename) 605AC_CHECK_FUNCS(basename poll)
605 606
606AC_MSG_CHECKING(return type of socket size) 607AC_MSG_CHECKING(return type of socket size)
607AC_TRY_COMPILE([#include <stdlib.h> 608AC_TRY_COMPILE([#include <stdlib.h>
@@ -1263,20 +1264,6 @@ AC_ARG_WITH(rpcinfo_command,
1263 [sets path to rpcinfo]), PATH_TO_RPCINFO=$withval) 1264 [sets path to rpcinfo]), PATH_TO_RPCINFO=$withval)
1264AC_DEFINE_UNQUOTED(PATH_TO_RPCINFO,"$PATH_TO_RPCINFO",[path to rpcinfo binary]) 1265AC_DEFINE_UNQUOTED(PATH_TO_RPCINFO,"$PATH_TO_RPCINFO",[path to rpcinfo binary])
1265 1266
1266AC_PATH_PROG(PATH_TO_NTPDATE,ntpdate)
1267AC_ARG_WITH(ntpdate_command,
1268 ACX_HELP_STRING([--with-ntpdate-command=PATH],
1269 [sets path to ntpdate]), PATH_TO_NTPDATE=$withval)
1270AC_PATH_PROGS(PATH_TO_NTPDC,ntpdc xntpdc)
1271AC_PATH_PROGS(PATH_TO_NTPQ,ntpq)
1272if (test -n "$PATH_TO_NTPDATE" || test -n "$PATH_TO_NTPQ")
1273then
1274 AC_DEFINE_UNQUOTED(PATH_TO_NTPQ,"$PATH_TO_NTPQ",[path to ntpq binary])
1275 AC_DEFINE_UNQUOTED(PATH_TO_NTPDATE,"$PATH_TO_NTPDATE",[path to ntpdate binary])
1276else
1277 AC_MSG_WARN([Install NTP programs (http://www.ntp.org) if you want to monitor time synchronization])
1278fi
1279
1280AC_PATH_PROG(PATH_TO_LMSTAT,lmstat) 1267AC_PATH_PROG(PATH_TO_LMSTAT,lmstat)
1281if test -x "$PATH_TO_LMSTAT" 1268if test -x "$PATH_TO_LMSTAT"
1282then 1269then
@@ -1621,6 +1608,19 @@ if test -n "$PATH_TO_DIG"; then
1621 AC_DEFINE_UNQUOTED(PATH_TO_DIG,"$PATH_TO_DIG",[Path to dig command, if present]) 1608 AC_DEFINE_UNQUOTED(PATH_TO_DIG,"$PATH_TO_DIG",[Path to dig command, if present])
1622fi 1609fi
1623 1610
1611AC_PATH_PROG(PATH_TO_APTGET,apt-get)
1612AC_ARG_WITH(apt-get_command,
1613 ACX_HELP_STRING([--with-apt-get-command=PATH],
1614 [Path to apt-get command]),
1615 with_apt_get_command=$withval,
1616 with_apt_get_command=$PATH_TO_APTGET)
1617AC_DEFINE_UNQUOTED(PATH_TO_APTGET,"$PATH_TO_APTGET",[Path to apt-get command, if present])
1618# check_apt needs regex support
1619if test -n "$PATH_TO_APTGET" && test "$FOUNDREGEX" = "yes"; then
1620 EXTRAS="$EXTRAS check_apt"
1621fi
1622
1623
1624if test -f plugins/check_nt.c ; then 1624if test -f plugins/check_nt.c ; then
1625 EXTRAS="$EXTRAS check_nt" 1625 EXTRAS="$EXTRAS check_nt"
1626elif test -f ../plugins/check_nt.c ; then 1626elif test -f ../plugins/check_nt.c ; then
@@ -1718,11 +1718,11 @@ dnl the ones below that are commented out need to be cleaned up
1718dnl in the configure code above to use with_foo instead of ac_cv_foo 1718dnl in the configure code above to use with_foo instead of ac_cv_foo
1719dnl if we want them to show up here. it'd also make the code cleaner. 1719dnl if we want them to show up here. it'd also make the code cleaner.
1720dnl i'll get to that on another rainy day :) -sf 1720dnl i'll get to that on another rainy day :) -sf
1721ACX_FEATURE([with],[apt-get-command])
1721dnl ACX_FEATURE([with],[dig-command]) 1722dnl ACX_FEATURE([with],[dig-command])
1722dnl ACX_FEATURE([with],[fping-command]) 1723dnl ACX_FEATURE([with],[fping-command])
1723dnl ACX_FEATURE([with],[mailq-command]) 1724dnl ACX_FEATURE([with],[mailq-command])
1724dnl ACX_FEATURE([with],[nslookup-command]) 1725dnl ACX_FEATURE([with],[nslookup-command])
1725dnl ACX_FEATURE([with],[ntpdate-command])
1726ACX_FEATURE([with],[ping6-command]) 1726ACX_FEATURE([with],[ping6-command])
1727ACX_FEATURE([with],[ping-command]) 1727ACX_FEATURE([with],[ping-command])
1728dnl ACX_FEATURE([with],[qstat-command]) 1728dnl ACX_FEATURE([with],[qstat-command])