summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSebastian Harl <sh@teamix.net>2011-04-07 15:24:23 (GMT)
committerSebastian Harl <sh@teamix.net>2012-06-06 12:10:55 (GMT)
commitf9a942d2a11e70ee68d5ea2c9aa762bff004bf43 (patch)
tree31ce3a05d1bdc715bf7a0230280d1d16940212ad /configure.in
parent804e7d878cad5c76474fd2abf2130ff446dbda5d (diff)
downloadmonitoring-plugins-f9a942d2a11e70ee68d5ea2c9aa762bff004bf43.tar.gz
Initial version of the 'check_dbi' plugin.
This plugin connects to an SQL database using libdbi, thus supporting all database backends supported by libdbi. It will then issue the specified SQL query and check the result (the numeric value of the first column of the first row to be precise) against the specified warning/critical ranges. The performance data includes the connection time (µs-resolution as provided by gettimeofday()) and the query result.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e8fc789..072d674 100644
--- a/configure.in
+++ b/configure.in
@@ -255,6 +255,19 @@ fi
255LIBS="$_SAVEDLIBS" 255LIBS="$_SAVEDLIBS"
256CPPFLAGS="$_SAVEDCPPFLAGS" 256CPPFLAGS="$_SAVEDCPPFLAGS"
257 257
258dnl Check for DBI libraries
259_SAVEDLIBS="$LIBS"
260AC_CHECK_LIB(dbi,dbi_initialize)
261if test "$ac_cv_lib_dbi_dbi_initialize" = "yes"; then
262 EXTRAS="$EXTRAS check_dbi"
263 DBILIBS="-ldbi"
264 AC_SUBST(DBILIBS)
265else
266 AC_MSG_WARN([Skipping dbi plugin])
267 AC_MSG_WARN([install DBI libs to compile this plugin (see REQUIREMENTS).])
268fi
269LIBS="$_SAVEDLIBS"
270
258dnl Check for radius libraries 271dnl Check for radius libraries
259_SAVEDLIBS="$LIBS" 272_SAVEDLIBS="$LIBS"
260AC_CHECK_LIB(radiusclient,rc_read_config) 273AC_CHECK_LIB(radiusclient,rc_read_config)