summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2006-07-13 12:50:23 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2006-07-13 12:50:23 (GMT)
commit548083b2ea865474915fc8a9ddd361e997585a02 (patch)
treef3766c1f5d8f8ea1b2b721a5792e4fb4daf1cf68 /lib/Makefile.am
parent6b9cc76d0a27631fbab19a31ab8bd46e143b7580 (diff)
downloadmonitoring-plugins-548083b2ea865474915fc8a9ddd361e997585a02.tar.gz
Move new util_* functions to lib/
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1451 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 9a8991e..0f40bf1 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,5 +1,7 @@
1## Process this file with automake to produce Makefile.in 1## Process this file with automake to produce Makefile.in
2 2
3SUBDIRS = tests
4
3noinst_LIBRARIES = libcoreutils.a libnagiosplug.a 5noinst_LIBRARIES = libcoreutils.a libnagiosplug.a
4 6
5# Will auto pick up fsusage.c mountlist.c 7# Will auto pick up fsusage.c mountlist.c
@@ -39,13 +41,16 @@ other_coreutils_files = \
39libcoreutils_a_LIBADD = $(LIBOBJS) 41libcoreutils_a_LIBADD = $(LIBOBJS)
40libcoreutils_a_DEPENDENCIES = $(libcoreutils_a_LIBADD) 42libcoreutils_a_DEPENDENCIES = $(libcoreutils_a_LIBADD)
41 43
42libnagiosplug_a_SOURCES = snprintf.c 44libnagiosplug_a_SOURCES = snprintf.c utils_base.c utils_disk.c
43 45
44INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl 46INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl -I$(top_srcdir)/plugins
45 47
46print_coreutil_files: 48print_coreutil_files:
47 @echo $(libcoreutils_a_SOURCES) $(other_coreutils_files) $(EXTRA_DIST) 49 @echo $(libcoreutils_a_SOURCES) $(other_coreutils_files) $(EXTRA_DIST)
48 50
51test:
52 cd tests && make test
53
49# Below are from coreutil's lib/Makefile.am 54# Below are from coreutil's lib/Makefile.am
50BUILT_SOURCES = $(STDBOOL_H) 55BUILT_SOURCES = $(STDBOOL_H)
51EXTRA_DIST += stdbool_.h 56EXTRA_DIST += stdbool_.h