summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2004-12-15 20:47:26 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2004-12-15 20:47:26 (GMT)
commit82d1989d3245791c9fac22ca848f5497f261c10b (patch)
tree240017a6fcdcf7ecb5cfb2cbefb57de24de8b7c7 /lib/Makefile.am
parent953a933e4d5900ec3c497781dab26066fef1e78b (diff)
downloadmonitoring-plugins-82d1989d3245791c9fac22ca848f5497f261c10b.tar.gz
Moving m4 files into m4/. Added extra coreutils files required from
autoconf tests. Updated Makefile.am to have nagiosplug lib and a separate coreutils lib git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1027 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am44
1 files changed, 31 insertions, 13 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 3250cdb..80f3e62 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,20 +1,38 @@
1## Process this file with automake to produce Makefile.in 1## Process this file with automake to produce Makefile.in
2 2
3noinst_LIBRARIES = libnagiosplug.a 3noinst_LIBRARIES = libcoreutils.a libnagiosplug.a
4 4
5libnagiosplug_a_SOURCES = getopt.c getopt1.c fsusage.c snprintf.c mountlist.c \ 5# Will auto pick up fsusage.c mountlist.c
6 xmalloc.c xstrdup.c exitfail.c 6libcoreutils_a_SOURCES = \
7 cloexec.c cloexec.h \
8 exit.h \
9 exitfail.c exitfail.h \
10 fsusage.h \
11 full-read.c full-read.h \
12 full-write.c full-write.h \
13 getopt.c getopt.h getopt1.c \
14 gettext.h \
15 mountlist.h \
16 safe-read.c safe-read.h \
17 safe-write.c safe-write.h \
18 unlocked-io.h \
19 xalloc.h \
20 xmalloc.c \
21 xstrdup.c
7 22
8libnagiosplug_a_LIBADD = @LIBOBJS@ 23other_coreutils_files = \
9libnagiosplug_a_DEPENDENCIES = $(libnagiosplug_a_LIBADD) 24 error.c error.h \
25 fsusage.c \
26 getloadaavg.c \
27 malloc.c \
28 mountlist.c \
29 realloc.c \
30 strtod.c
10 31
11# Extra GNU libraries required if target is missing these functions 32libcoreutils_a_LIBADD = $(LIBOBJS)
12EXTRA_DIST = ulonglong.m4 codeset.m4 gettext.m4 glibc21.m4 iconv.m4 intdiv0.m4 \ 33libcoreutils_a_DEPENDENCIES = $(libcoreutils_a_LIBADD)
13 inttypes.m4 inttypes_h.m4 inttypes-pri.m4 isc-posix.m4 lcmessage.m4 lib-ld.m4 \ 34
14 lib-link.m4 lib-prefix.m4 progtest.m4 stdint_h.m4 uintmax_t.m4 afs.m4 \ 35libnagiosplug_a_SOURCES = snprintf.c
15 fstypename.m4 fsusage.m4 ls-mntd-fs.m4 getopt.h gettext.h fsusage.h mountlist.h\
16 error.m4 error.h error.c getloadavg.c xalloc.h unlocked-io.h unlocked-io.m4 malloc.c \
17 onceonly.m4 realloc.c strtod.c exitfail.h full-read.h xstrdup.c xalloc.m4 exit.h \
18 cloexec.c cloexec.h getopt.m4 exitfail.m4
19 36
20INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl 37INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl
38