summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2006-11-03 15:40:33 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2006-11-03 15:40:33 (GMT)
commita5a4996a639101859bc183c85b33a6e04f5133f9 (patch)
tree67a3017ae2353ae1f9d39a8461d85314d22efaef /lib/Makefile.am
parentfea92b5c044330a3c6dcc3438bebb9c18ccfc971 (diff)
downloadmonitoring-plugins-a5a4996a639101859bc183c85b33a6e04f5133f9.tar.gz
Add alloca files, required for *BSD
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1534 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 8045569..7edac1f 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -38,8 +38,9 @@ other_coreutils_files = \
38 xmalloc.c 38 xmalloc.c
39 39
40 40
41libcoreutils_a_LIBADD = $(LIBOBJS) 41libcoreutils_a_LIBADD = $(LIBOBJS) $(ALLOCA)
42libcoreutils_a_DEPENDENCIES = $(libcoreutils_a_LIBADD) 42libcoreutils_a_DEPENDENCIES = $(libcoreutils_a_LIBADD)
43lib_OBJECTS = $(libcoreutils_a_OBJECTS)
43 44
44libnagiosplug_a_SOURCES = snprintf.c utils_base.c utils_disk.c 45libnagiosplug_a_SOURCES = snprintf.c utils_base.c utils_disk.c
45EXTRA_DIST += utils_base.h utils_disk.h 46EXTRA_DIST += utils_base.h utils_disk.h
@@ -61,6 +62,17 @@ stdbool.h: stdbool_.h
61 sed -e 's/@''HAVE__BOOL''@/$(HAVE__BOOL)/g' $(srcdir)/stdbool_.h > $@t 62 sed -e 's/@''HAVE__BOOL''@/$(HAVE__BOOL)/g' $(srcdir)/stdbool_.h > $@t
62 mv $@t $@ 63 mv $@t $@
63 64
65BUILT_SOURCES += $(ALLOCA_H)
66EXTRA_DIST += alloca_.h
67
68# We need the following in order to create an <alloca.h> when the system
69# doesn't have one that works with the given compiler
70all-local $(lib_OBJECTS): $(ALLOCA_H)
71alloca.h: alloca_.h
72 cp $(srcdir)/alloca_.h $@-t
73 mv $@-t $@
74MOSTLYCLEANFILES += alloca.h alloca.h-t
75
64BUILT_SOURCES += $(GETOPT_H) 76BUILT_SOURCES += $(GETOPT_H)
65EXTRA_DIST += getopt_.h getopt_int.h 77EXTRA_DIST += getopt_.h getopt_int.h
66 78