summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2006-05-18 22:05:43 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2006-05-18 22:05:43 (GMT)
commita8cd7705e7898d77764aa12ddcc2e29de1860138 (patch)
tree970f609cbecbe515998907fd55a12f814ad2edcd /lib/Makefile.am
parent08394ddb2d62ec8aab9121e45ab9c1a102e85ba4 (diff)
downloadmonitoring-plugins-a8cd7705e7898d77764aa12ddcc2e29de1860138.tar.gz
Synchronise with coreutils 2.95. Gettext now synced with coreutils,
so no longer development platform requirement git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1394 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am38
1 files changed, 26 insertions, 12 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 0612a75..0d69089 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -6,29 +6,28 @@ noinst_LIBRARIES = libcoreutils.a libnagiosplug.a
6libcoreutils_a_SOURCES = \ 6libcoreutils_a_SOURCES = \
7 cloexec.c cloexec.h \ 7 cloexec.c cloexec.h \
8 exit.h \ 8 exit.h \
9 exitfail.c exitfail.h \
10 fsusage.h \
11 full-read.c full-read.h \ 9 full-read.c full-read.h \
12 full-write.c full-write.h \ 10 full-write.c full-write.h \
13 getopt.c getopt.h getopt1.c \
14 gettext.h \ 11 gettext.h \
15 mountlist.h \
16 safe-read.c safe-read.h \ 12 safe-read.c safe-read.h \
17 safe-write.c safe-write.h \ 13 safe-write.c safe-write.h xalloc-die.c
18 unlocked-io.h \
19 xalloc.h \
20 xmalloc.c \
21 xstrdup.c
22 14
23other_coreutils_files = \ 15other_coreutils_files = \
24 error.c error.h \ 16 error.c error.h \
25 fsusage.c \ 17 fsusage.c \
26 getloadaavg.c \ 18 getloadavg.c \
27 malloc.c \ 19 malloc.c \
28 mountlist.c \ 20 mountlist.c \
29 realloc.c \ 21 realloc.c \
30 stdbool_.h \ 22 strtod.c \
31 strtod.c 23 exitfail.c exitfail.h \
24 fsusage.h \
25 getopt.c getopt1.c \
26 mountlist.h \
27 unlocked-io.h \
28 xalloc.h \
29 xmalloc.c
30
32 31
33libcoreutils_a_LIBADD = $(LIBOBJS) 32libcoreutils_a_LIBADD = $(LIBOBJS)
34libcoreutils_a_DEPENDENCIES = $(libcoreutils_a_LIBADD) 33libcoreutils_a_DEPENDENCIES = $(libcoreutils_a_LIBADD)
@@ -37,6 +36,10 @@ libnagiosplug_a_SOURCES = snprintf.c
37 36
38INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl 37INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl
39 38
39print_coreutil_files:
40 @echo $(libcoreutils_a_SOURCES) $(other_coreutils_files) $(EXTRA_DIST)
41
42# Below are from coreutil's lib/Makefile.am
40BUILT_SOURCES = $(STDBOOL_H) 43BUILT_SOURCES = $(STDBOOL_H)
41EXTRA_DIST = stdbool_.h 44EXTRA_DIST = stdbool_.h
42MOSTLYCLEANFILES = stdbool.h stdbool.ht 45MOSTLYCLEANFILES = stdbool.h stdbool.ht
@@ -45,3 +48,14 @@ stdbool.h: stdbool_.h
45 sed -e 's/@''HAVE__BOOL''@/$(HAVE__BOOL)/g' $(srcdir)/stdbool_.h > $@t 48 sed -e 's/@''HAVE__BOOL''@/$(HAVE__BOOL)/g' $(srcdir)/stdbool_.h > $@t
46 mv $@t $@ 49 mv $@t $@
47 50
51BUILT_SOURCES += $(GETOPT_H)
52EXTRA_DIST += getopt_.h getopt_int.h
53
54# We need the following in order to create an <getopt.h> when the system
55# doesn't have one that works with the given compiler.
56all-local $(lib_OBJECTS): $(GETOPT_H)
57getopt.h: getopt_.h
58 cp $(srcdir)/getopt_.h $@-t
59 mv $@-t $@
60MOSTLYCLEANFILES += getopt.h getopt.h-t
61