summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2004-12-21 09:32:45 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2004-12-21 09:32:45 (GMT)
commitcf812dff06cdd8166366009b45142ba3db41e619 (patch)
treef404a259fa889bb07e2c71b283638e8150f5cbfa /lib/Makefile.am
parente22914b7ff9b863665f6e2ad19527b5cf9c4b839 (diff)
downloadmonitoring-plugins-cf812dff06cdd8166366009b45142ba3db41e619.tar.gz
Fixed compile problem on Sol2.6 with stdbool.h
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1047 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 80f3e62..9cab14a 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -36,3 +36,11 @@ libnagiosplug_a_SOURCES = snprintf.c
36 36
37INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl 37INCLUDES = -I$(srcdir) -I$(top_srcdir)/intl
38 38
39BUILT_SOURCES = $(STDBOOL_H)
40EXTRA_DIST = stdbool_.h
41MOSTLYCLEANFILES = stdbool.h stdbool.ht
42# Create stdbool.h on systems that lack a working one.
43stdbool.h: stdbool_.h
44 sed -e 's/@''HAVE__BOOL''@/$(HAVE__BOOL)/g' $(srcdir)/stdbool_.h > $@t
45 mv $@t $@
46