summaryrefslogtreecommitdiffstats
path: root/lib/tests/Makefile.am
diff options
context:
space:
mode:
authorThomas Guyot-Sionnest <dermoth@users.sourceforge.net>2008-04-02 09:11:44 (GMT)
committerThomas Guyot-Sionnest <dermoth@users.sourceforge.net>2008-04-02 09:11:44 (GMT)
commit0d13deb0e44afb80ec0a35e827548d891d48f6b6 (patch)
tree7723807c1c17109104f6ebf3fea141e87a50ba46 /lib/tests/Makefile.am
parent63897a417917907099b72f4e679890355a7a78a0 (diff)
downloadmonitoring-plugins-0d13deb0e44afb80ec0a35e827548d891d48f6b6.tar.gz
- Add --enable-extra-opts configure option for compiling extra-opts support
- Auto-update po/pot files git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1973 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/tests/Makefile.am')
-rw-r--r--lib/tests/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/lib/tests/Makefile.am b/lib/tests/Makefile.am
index bd25ccf..25e2bed 100644
--- a/lib/tests/Makefile.am
+++ b/lib/tests/Makefile.am
@@ -7,9 +7,11 @@ check_PROGRAMS = @EXTRA_TEST@
7 7
8INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins 8INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins
9 9
10EXTRA_PROGRAMS = test_utils test_disk test_tcp test_cmd test_base64 10EXTRA_PROGRAMS = test_utils test_disk test_tcp test_cmd test_base64 test_ini test_opts
11 11
12EXTRA_DIST = test_utils.t test_disk.t test_tcp.t test_cmd.t test_base64.t 12np_test_scripts = test_base64.t test_cmd.t test_disk.t test_ini.t test_opts.t test_tcp.t test_utils.t
13np_test_files = config-dos.ini config-opts.ini config-tiny.ini plugin.ini plugins.ini
14EXTRA_DIST = $(np_test_scripts) $(np_test_files)
13 15
14LIBS = @LIBINTL@ 16LIBS = @LIBINTL@
15 17
@@ -38,6 +40,16 @@ test_base64_CFLAGS = -g -I..
38test_base64_LDFLAGS = -L/usr/local/lib -ltap 40test_base64_LDFLAGS = -L/usr/local/lib -ltap
39test_base64_LDADD = $(top_srcdir)/gl/base64.o 41test_base64_LDADD = $(top_srcdir)/gl/base64.o
40 42
43test_ini_SOURCES = test_ini.c
44test_ini_CFLAGS = -g -I..
45test_ini_LDFLAGS = -L/usr/local/lib -ltap
46test_ini_LDADD = ../utils_base.o ../parse_ini.o
47
48test_opts_SOURCES = test_opts.c
49test_opts_CFLAGS = -g -I..
50test_opts_LDFLAGS = -L/usr/local/lib -ltap
51test_opts_LDADD = ../utils_base.o ../parse_ini.o ../extra_opts.o
52
41test: ${noinst_PROGRAMS} 53test: ${noinst_PROGRAMS}
42 perl -MTest::Harness -e '$$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS) 54 perl -MTest::Harness -e '$$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS)
43 55