summaryrefslogtreecommitdiffstats
path: root/lib/tests/Makefile.am
diff options
context:
space:
mode:
authorThomas Guyot-Sionnest <dermoth@users.sourceforge.net>2007-11-09 22:01:33 (GMT)
committerThomas Guyot-Sionnest <dermoth@users.sourceforge.net>2007-11-09 22:01:33 (GMT)
commit1ac40064c5d0cd6a592e69b47bc72ce9b1fd7e1c (patch)
treec56ed477cf30e0c47055972636c5844284abc17f /lib/tests/Makefile.am
parent7a05ad0166ac11d4206d934825728b56a58d8edd (diff)
downloadmonitoring-plugins-1ac40064c5d0cd6a592e69b47bc72ce9b1fd7e1c.tar.gz
Adding test for base64 lib
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1818 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/tests/Makefile.am')
-rw-r--r--lib/tests/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/lib/tests/Makefile.am b/lib/tests/Makefile.am
index 9ca22d1..e7bbb76 100644
--- a/lib/tests/Makefile.am
+++ b/lib/tests/Makefile.am
@@ -7,9 +7,9 @@ check_PROGRAMS = @EXTRA_TEST@
7 7
8INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins 8INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/plugins
9 9
10EXTRA_PROGRAMS = test_utils test_disk test_tcp test_cmd 10EXTRA_PROGRAMS = test_utils test_disk test_tcp test_cmd test_base64
11 11
12EXTRA_DIST = test_utils.t test_disk.t test_tcp.t test_cmd.t 12EXTRA_DIST = test_utils.t test_disk.t test_tcp.t test_cmd.t test_base64.t
13 13
14LIBS = @LIBINTL@ 14LIBS = @LIBINTL@
15 15
@@ -33,6 +33,11 @@ test_cmd_CFLAGS = -g -I..
33test_cmd_LDFLAGS = -L/usr/local/lib -ltap 33test_cmd_LDFLAGS = -L/usr/local/lib -ltap
34test_cmd_LDADD = ../utils_cmd.o ../utils_base.o 34test_cmd_LDADD = ../utils_cmd.o ../utils_base.o
35 35
36test_base64_SOURCES = test_base64.c
37test_base64_CFLAGS = -g -I..
38test_base64_LDFLAGS = -L/usr/local/lib -ltap
39test_base64_LDADD = ../base64.o
40
36test: ${noinst_PROGRAMS} 41test: ${noinst_PROGRAMS}
37 perl -MTest::Harness -e '$$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS) 42 perl -MTest::Harness -e '$$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS)
38 43