summaryrefslogtreecommitdiffstats
path: root/lib/tests/Makefile.am
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2006-07-13 12:50:23 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2006-07-13 12:50:23 (GMT)
commit548083b2ea865474915fc8a9ddd361e997585a02 (patch)
treef3766c1f5d8f8ea1b2b721a5792e4fb4daf1cf68 /lib/tests/Makefile.am
parent6b9cc76d0a27631fbab19a31ab8bd46e143b7580 (diff)
downloadmonitoring-plugins-548083b2ea865474915fc8a9ddd361e997585a02.tar.gz
Move new util_* functions to lib/
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1451 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'lib/tests/Makefile.am')
-rw-r--r--lib/tests/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/lib/tests/Makefile.am b/lib/tests/Makefile.am
new file mode 100644
index 0000000..63dee76
--- /dev/null
+++ b/lib/tests/Makefile.am
@@ -0,0 +1,28 @@
1
2noinst_PROGRAMS = @EXTRA_TEST@
3
4# These two lines support "make check", but we use "make test"
5TESTS = @EXTRA_TEST@
6check_PROGRAMS = @EXTRA_TEST@
7
8INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/intl -I$(top_srcdir)/plugins
9
10EXTRA_PROGRAMS = test_utils test_disk
11
12EXTRA_DIST = test_utils.t test_disk.t
13
14LIBS = @LIBINTL@
15
16test_utils_SOURCES = test_utils.c
17test_utils_CFLAGS = -g -I..
18test_utils_LDFLAGS = -L/usr/local/lib -ltap
19test_utils_LDADD = ../utils_base.o
20
21test_disk_SOURCES = test_disk.c
22test_disk_CFLAGS = -g -I..
23test_disk_LDFLAGS = -L/usr/local/lib -ltap
24test_disk_LDADD = ../utils_disk.o
25
26test: ${noinst_PROGRAMS}
27 perl -MTest::Harness -e '$$Test::Harness::switches=""; runtests(map {$$_ .= ".t"} @ARGV)' $(EXTRA_PROGRAMS)
28