summaryrefslogtreecommitdiffstats
path: root/plugins-root/Makefile.am
diff options
context:
space:
mode:
authorTon Voon <tonvoon@users.sourceforge.net>2006-06-07 07:18:12 (GMT)
committerTon Voon <tonvoon@users.sourceforge.net>2006-06-07 07:18:12 (GMT)
commitb2363e2914cd798f5fa230b31902da906795c9d6 (patch)
tree53ed207efb0a3524734a0a0f7154570b3cd80e19 /plugins-root/Makefile.am
parent73255d1551f787151a518e35b1fbc175a4150133 (diff)
downloadmonitoring-plugins-b2363e2914cd798f5fa230b31902da906795c9d6.tar.gz
Fixed two build problems re: libtool and pst3
git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1415 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'plugins-root/Makefile.am')
-rw-r--r--plugins-root/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/plugins-root/Makefile.am b/plugins-root/Makefile.am
index 2a2987d..f5ecc46 100644
--- a/plugins-root/Makefile.am
+++ b/plugins-root/Makefile.am
@@ -33,7 +33,7 @@ group = nagios
33# /* Author Coreutils team - see ACKNOWLEDGEMENTS */ 33# /* Author Coreutils team - see ACKNOWLEDGEMENTS */
34 34
35INSTALL_SUID = \ 35INSTALL_SUID = \
36 for f in $(EXTRA_PROGRAMS) ; do \ 36 for f in $(libexec_PROGRAMS) ; do \
37 p=$$f; \ 37 p=$$f; \
38 echo " $(INSTALL_PROGRAM) $$p $(DESTDIR)$(libexecdir)/$$p"; \ 38 echo " $(INSTALL_PROGRAM) $$p $(DESTDIR)$(libexecdir)/$$p"; \
39 $(INSTALL_PROGRAM) $$p $(DESTDIR)$(libexecdir)/$$p; \ 39 $(INSTALL_PROGRAM) $$p $(DESTDIR)$(libexecdir)/$$p; \
@@ -43,10 +43,10 @@ INSTALL_SUID = \
43 chmod $(setuid_root_mode) $(DESTDIR)$(libexecdir)/$$p; \ 43 chmod $(setuid_root_mode) $(DESTDIR)$(libexecdir)/$$p; \
44 done 44 done
45 45
46install-root: $(EXTRA_PROGRAMS) 46install-root: $(libexec_PROGRAMS)
47 @$(INSTALL_SUID) 47 @$(INSTALL_SUID)
48 48
49install-exec-local: $(EXTRA_PROGRAMS) 49install-exec-local: $(libexec_PROGRAMS)
50 @TMPFILE=$(DESTDIR)$(libexecdir)/.setuid-$$$$; \ 50 @TMPFILE=$(DESTDIR)$(libexecdir)/.setuid-$$$$; \
51 rm -f $$TMPFILE; \ 51 rm -f $$TMPFILE; \
52 echo > $$TMPFILE; \ 52 echo > $$TMPFILE; \