summaryrefslogtreecommitdiffstats
path: root/plugins-scripts/Makefile.am
diff options
context:
space:
mode:
authorHolger Weiss <holger@zedat.fu-berlin.de>2014-07-06 17:55:03 (GMT)
committerHolger Weiss <holger@zedat.fu-berlin.de>2014-07-06 17:55:03 (GMT)
commit1f4fd12845a2041df3f34f7a84d8012e747e327c (patch)
tree1524e7a4def106f54d86b36ea3a114638b1141d6 /plugins-scripts/Makefile.am
parentba21e26443385dd283d08e0419ff6ff25fedd0e8 (diff)
downloadmonitoring-plugins-1f4fd12.tar.gz
Don't rely on FindBin module to locate utils.pm
As the FindBin module doesn't work with ePN, set the path to utils.pm explicitly at build time. Keep using FindBin additionally, so that the plugins can also be executed from the build directory. Closes #1271.
Diffstat (limited to 'plugins-scripts/Makefile.am')
-rw-r--r--plugins-scripts/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/plugins-scripts/Makefile.am b/plugins-scripts/Makefile.am
index 78a950c..794a34f 100644
--- a/plugins-scripts/Makefile.am
+++ b/plugins-scripts/Makefile.am
@@ -26,7 +26,8 @@ EXTRA_DIST=check_breeze.pl check_disk_smb.pl check_flexlm.pl check_ircd.pl \
26EDIT = sed \ 26EDIT = sed \
27 -e 's|[@]NP_VERSION[@]|$(NP_VERSION)|g' \ 27 -e 's|[@]NP_VERSION[@]|$(NP_VERSION)|g' \
28 -e 's|[@]TRUSTED_PATH[@]|$(with_trusted_path)|g' \ 28 -e 's|[@]TRUSTED_PATH[@]|$(with_trusted_path)|g' \
29 -e 's|[@]PERL[@]|$(PERL)|g' 29 -e 's|[@]PERL[@]|$(PERL)|g' \
30 -e 's|[@]libexecdir[@]|$(libexecdir)|g'
30 31
31TESTS_ENVIRONMENT=perl -I $(top_builddir) -I $(top_srcdir) 32TESTS_ENVIRONMENT=perl -I $(top_builddir) -I $(top_srcdir)
32 33