summaryrefslogtreecommitdiffstats
path: root/plugins-scripts/Makefile.am
diff options
context:
space:
mode:
authorM. Sean Finney <seanius@users.sourceforge.net>2006-05-01 21:52:42 (GMT)
committerM. Sean Finney <seanius@users.sourceforge.net>2006-05-01 21:52:42 (GMT)
commite667553b97c358f5d80608f62c291deffc0328d5 (patch)
tree4e74625613f8d13f51752d84f03b436b45164ff7 /plugins-scripts/Makefile.am
parent3b91dfbcb05dbfa9a1a20c6ba233c5d163e06821 (diff)
downloadmonitoring-plugins-e667553b97c358f5d80608f62c291deffc0328d5.tar.gz
- check_ntp:
- now roughly feature-complete. - various bugfixes, esp. offset calculation. - enhanced the asynchronous offset polling to set requests that haven't recieved a response in >= 1 second to stale and retransmit them, which results in much better performance on unreliable networks. - we only spend timeout/2 seconds polling offsets, and if we don't get everything by that point we work with what we have and set status to warning/critical depending on how much data we have. - set the same defaults as the perl script. - commit changes to configure.in to support automatic building of check_apt (if apt-get is installed and regex libraries available) and check_ntp (unconditionally), now defaulting to check_ntp.c instead of the perl script. if this is an issue we can back out the commit of course. an eye should be kept on check_ntp building and running correctly in different environments, esp. 64-bit and big-endian platforms, and those with more "esoteric" API's (do any of the platforms not have poll()?). - similar changes to Makefile.am's. - common.h: add statement to include sys/poll.h - runcmd.c: exit STATE_UNKNOWN if execve() fails. git-svn-id: https://nagiosplug.svn.sourceforge.net/svnroot/nagiosplug/nagiosplug/trunk@1386 f882894a-f735-0410-b71e-b25c423dba1c
Diffstat (limited to 'plugins-scripts/Makefile.am')
-rw-r--r--plugins-scripts/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/plugins-scripts/Makefile.am b/plugins-scripts/Makefile.am
index 5556cf6..9de45d5 100644
--- a/plugins-scripts/Makefile.am
+++ b/plugins-scripts/Makefile.am
@@ -5,7 +5,7 @@ SUFFIXES = .pl .sh
5VPATH=$(top_srcdir) $(top_srcdir)/plugins-scripts $(top_srcdir)/plugins-scripts/t 5VPATH=$(top_srcdir) $(top_srcdir)/plugins-scripts $(top_srcdir)/plugins-scripts/t
6 6
7libexec_SCRIPTS = check_breeze check_disk_smb check_flexlm check_ircd \ 7libexec_SCRIPTS = check_breeze check_disk_smb check_flexlm check_ircd \
8 check_log check_ntp check_oracle check_rpc check_sensors check_wave \ 8 check_log check_oracle check_rpc check_sensors check_wave \
9 check_ifstatus check_ifoperstatus check_mailq check_file_age \ 9 check_ifstatus check_ifoperstatus check_mailq check_file_age \
10 utils.sh utils.pm 10 utils.sh utils.pm
11 11